Sign in with
Sign up | Sign in
Your question

Replaced a failing hard drive, now files are all corrupt!

Last response: in Storage
Share
April 24, 2012 2:41:55 PM

Hey Gang,

I hope this is the right thread...I know I'm gonna find someone on this forum that can help.

So, the storage drive in my home server started going bad after 3 months. WD sent a replacement through RMA and I used clonezilla to do the file copy.

Everything looked fine, but now I've found that most of the files are not working. When trying to open them, their various programs say they are not the correct file typs. They will open the program, word, WMP, etc, but then that program will say they're not recognized.

So, I tried File Repair and got the error message that the "file was empty". I tried DivFix++ on the .avi's but it doesn't see them as .avi's.

The files are "there". The correct size and file extension is on them. They copy off the server onto my office machine but still don't work there.

I really need to find a solution to this. I've been backing up that hard drive to an external drive but I would guess the back-up has the same problem now.

Help!!
a b G Storage
April 24, 2012 4:09:13 PM

have you tried running error checking tool?
m
0
l
a c 372 G Storage
April 24, 2012 4:21:06 PM

Does your ram check out ok? Data from ram gets written to disk. If it's corrupt in memory, it gets written to disk that way. Of course, if you had ram issues, you should also be seeing some other related problems. It can't hurt to run a few passes of memtest86+ though.

Also, if you have a P67 chipset, it may be the sata bug.

http://www.anandtech.com/show/4142/intel-discovers-bug-...

http://www.anandtech.com/show/4143/the-source-of-intels...
m
0
l
Related resources
!