Sign in with
Sign up | Sign in
Your question

Sapphire 5850 & Resident Evil 5 issue

Last response: in Graphics & Displays
Share
March 9, 2010 9:06:36 AM

I get very poor results on RE5 benchmark with my Sapphire 5850 (35 fps), when compared to the results submitted on this site and other places (81 fps). Other benchmarks I've done give me good results, like 3dmark vantage using high preset gives me a GPU score of 9404 (tom's hardware in the 5850 review gets 8700).
Any help as to why I'm getting such poor results in Resident Evil 5 would be greatly appreciated.
March 9, 2010 9:30:28 AM

When comparing your results with site's benchmarks, you have to take in consideration other things like cpu, ram etc.. Are yo sure you have the same system? It could just be the case that you are running a 5850 with a poor cpu.
Tomshardware, for instance, is now benchmarking gpu using an i7-975 system.
Also check your settings. AA is specially taxing on gpus. If you reduce them, your results should improve.
m
0
l
March 9, 2010 9:55:47 AM

Sorry forgot to post my specs:
MB: MSI P55-CD53
CPU: i5-750
RAM: 4GB 1333Mhz
GPU: Sapphire 5850
HDD: WD 1TB Black

And its not the CPU because I've seen results from other sources with the same processor and the results are the same like those on tom's hardware.
As for the game settings I run them everything on full, same as the settings on the comparing results.
m
0
l
Related resources
March 9, 2010 10:36:37 AM

At what resolution do you game?
m
0
l
March 9, 2010 10:44:11 AM

Tom's results for 5850:
System set-up
i7-975@4Ghz, Asus Rampage II Extreme, 6Gb RAM.
Results for Resident Evil 5:
High Quality Settings, No AA / No AF, vsync off, DirectX 10, Fixed Benchmark:
100,5 fps@1680x1050, 87,6 fps@1920x1080, 63 fps@2560x1920
High Quality Settings, 8xAA / No AF, vsync off, DirectX 10, Fixed Benchmark:
92,9 fps@1680x1050, 81,1 fps@1920x1080, 58,4 fps@2560x1920
m
0
l
!