Sign in with
Sign up | Sign in
Your question
Solved

SSD RAID0 data takes up 2x space?

Last response: in Storage
Share
April 25, 2012 3:53:37 PM

I have 2x OCZ Agility 3 60GB SSDs in RAID0 using the Marvell controller on my MSI Big Bang X-power board. For some reason, the data is taking up way too much space. If i show hidden files and highlight everything and check the properties, it shows just over 40 GB of data. If I then right click C:\ and show properties, it shows that I am using 85 GB of capacity.

Anyone have any idea why everything is taking up double the space it should?
April 25, 2012 3:54:27 PM

If it is not clear, I can attach screenshots to show what I mean when I get home
m
0
l

Best solution

a c 99 G Storage
April 25, 2012 4:27:27 PM

Do you have native SATA III ports (Intel)? This is one of the many problems with the add-on Marvell controllers!

**Edit** Just looked for your mobo. Seems it is a LGA 1366 X58 chipet board, so you don't have native Intel SATA III ports.

How you done any SSD tweaks?

Try SSD Review: The SSD Optimization Guide

Or the OCZ Forum/Blog: SSD Tips and Tweaks

These will mostly save you space, but the root is the Marvell controller.

My suggestion would be a PCI RAID Card. THe SSD Review just reviewed one (with the new Intel 520 SSD), that lists for $160. Here is their reveiw: HighPoint 2720SGL RocketRAID Controller Review. One thing not mentioned it that you need to buy cables: SAS to SATA? I'm unsure about that.

Personally, I'd rather put those SATA III drives on Intel SATA II ports, than go with Marvell SATA III ports!
Share
Related resources
April 25, 2012 5:33:03 PM

I haven't done any SSD tweaks yet.

In order to set up the raid i had to change my SATA mode from AHCI to RAID, is that possibly causing a problem with TRIM or something?

The thing that really confuses me is that when I look at the properties of the files on the disk themselves it says that the "Size on disk" is something like 42.3 GB, but then it says that C:\ is using about 85 GB... why isn't it the same as the size of all the files on the SSD?

Unfortunately I don't have a lot of space in my case for a raid controller card (maybe could squeeze it between my graphics cards... but i'm not sure)
m
0
l
a c 99 G Storage
April 25, 2012 7:16:54 PM

No about TRIM. TRIM doesn't work in RAID, but it wouldn't cause your problems.

I go with moving them to an Intel SATA II port(s).

Change your boot order in BIOS.
m
0
l
April 25, 2012 7:25:07 PM

If i move them to the SATA II ports, will I have to reinstall everything or will the RAID somehow migrate? Also, if I move them to the SATA II ports, even in RAID they would barely out perform just 1 of them in a SATA III port.

Performance
Sustained Sequential Read
up to 525 MB/s (SATA 6Gbps)
up to 280 MB/s (SATA 3Gbps)
Sustained Sequential Write
up to 475 MB/s (SATA 6Gbps)
up to 260 MB/s (SATA 3Gbps)

m
0
l
a c 99 G Storage
April 25, 2012 7:32:06 PM

You should be ok with the move, but I'm not sure, as it was originally set up on Marvell, and you're moving to Intel. Need other experts to advise.

As far as SATA III vs SATA II, statisticilly you are right, but read this article from THG:
Upgrade Advice: Does Your Fast SSD Really Need SATA 6Gb/s?

This article really raised my eyebrows.

On a different note, I just changed my SSD from RAID 0 to one single larger SSD. I am pleased with its performance! But, I hardly noticed any difference between the SATA II SSD in RAID 0 on my wifes PC to the SATA III SSD in RAID 0 on mine. Boot times and launch times are almost the same. Now with just one larger SSD on mine, boot times are only 1 sec slower, if that.
m
0
l
a b G Storage
April 25, 2012 7:51:46 PM

Have you tried running windirstat to see what the extra space actually is?

http://windirstat.info/

I bet you can figure out what the space actually is being used by, and hopefully remove it from that point.

Would you mind linking where you read about the marvel controllers duplicating data foscooter?
m
0
l
a c 99 G Storage
April 25, 2012 8:06:22 PM

Not so much about Marvell duplicating data, just that the Marvell controllers aren't up to Intel spec/speeds.

I have 2 Marvell SATA III ports on my mobo (non-RAID), and when I did hook up a HDD to it, to copy ALOT of file over, it was slow! When I installed the drivers for the controller, it was actully slower! I have screenshots of ATTO to back this up! The generic Windows driver worked better the the manufactures drivers! I had similar problems with JMicron SATA ports in the past, so I just don't go ther anymore.

Now I understand if that is all you got to get to SATA III, but look what happened.

And the OP problem is not so much what is using up all his space, but why the difference between Windows Explorer, and the drive properties.

I think it is a System Restore Points, Hibernation files, and Pagefile issue. Try the tweaks before you do anything!
m
0
l
a b G Storage
April 25, 2012 8:21:27 PM

Just making sure, from your post it was a bit unclear on what you were inferring there.

Agreed on what is likely eating the space up which is why I was referring him to windirstat.

He is basically asking what is using the space which didn't seem to have been addressed.
m
0
l
April 26, 2012 12:26:31 AM

Solved - Thanks to both of you.

I ran Windirstat and found the problems - thanks tomatthe :) 

The problem was that I hadn't gone through the optimizations yet and for some reason the pagefile was set by default to 24 GB (equal to my RAM) and the hibersys file was another 19 GB. Using the optimization link from foscooter i got rid of the pagefile and turned off hibernate mode through command prompt.
m
0
l
April 26, 2012 12:34:59 AM

Best answer selected by ferguson005.
m
0
l
!