Sign in with
Sign up | Sign in
Your question

HD5970 and low FPS on Crysis

Last response: in Graphics & Displays
Share
March 9, 2010 9:16:26 PM

Hi All,

First post here so please let me begin by sayin "Hi" to all.

I have just built a new PC and am getting worryingly low FPS on Crysis.

The machine is as follows:

Mobo:ASUS Rampage II Extreme (BIOS ver 1704)
CPU: Intel Core i7 920 (O/clocked 4Ghz)
CPU Cooler: Corsair H50
RAM: 6Gb (3x2Gb) Corsair TwinX Dominator GT DDR3 1600Mhz (down from 2000)
HD: 300Gb Western Digital VelociRaptor
PSU: 850W CoolerMaster SilentPro
GPU: ASUS AEH5970 2Gb with ATI Catalyst ver 10.2 (Driver ver. 8.702.0.0)
Monitor: Samsung SyncMaster P2250 (1920 x 1080) 60 MHz refresh
OS: Windows 7 Professional x64

More about : hd5970 low fps crysis

March 9, 2010 9:22:49 PM

Bucks85th said:
Hi All,

First post here so please let me begin by sayin "Hi" to all.

I have just built a new PC and am getting worryingly low FPS on Crysis.

The machine is as follows:

Mobo:ASUS Rampage II Extreme (BIOS ver 1704)
CPU: Intel Core i7 920 (O/clocked 4Ghz)
CPU Cooler: Corsair H50
RAM: 6Gb (3x2Gb) Corsair TwinX Dominator GT DDR3 1600Mhz (down from 2000)
HD: 300Gb Western Digital VelociRaptor
PSU: 850W CoolerMaster SilentPro
GPU: ASUS AEH5970 2Gb with ATI Catalyst ver 10.2 (Driver ver. 8.702.0.0)
Monitor: Samsung SyncMaster P2250 (1920 x 1080) 60 MHz refresh
OS: Windows 7 Professional x64


Sorry! Posted before finishing...

According to the benchmarks, I would expect to be getting 40+ FPS but am averaging about 10 with all settings very high. I have tried none and 8x AA.

I have tried various driver versions and for 5 minutes on an older driver, managed to get about 40-50 FPS before the game crashed. Have not been able to get it since no matter what driver I try.

I have tried Crysis 1.2 and 1.2.1.

I have tried disabling ULPS.

I have tried in Vista compatibility mode.

I am getting a score of around 24,400 on 3DMark06 so I don't think anything is faulty.

Does anyone have any suggestions as to what the problem may be?

Many thanks in advance!

March 9, 2010 9:54:00 PM

Just making sure: no AF, right?
Related resources
March 9, 2010 10:03:45 PM

Thanks Galta,

Currently, I've not changed any GPU settings in the CCC so AF is left with the default 'Use application settings'.

Unfortunately, the only other game I have installed is WoW, which is hardly going to really test the machine.

I really only installed Crysis to see how the machine performed before heading out to get CoD:MW2, Clien Vs Predator & FarCry 2, and have been left feeling somewhat cold to be honest!

Cheers!

Bucks
March 9, 2010 10:17:52 PM

It might be driver related. Try going into Safe Mode and uninstall the video drivers. Then reboot and re-install the drivers again.
March 9, 2010 10:45:08 PM

Uh, What comes to mind is a similar problem i had. Turns out for soem reason, Crysis was running my card at idle speeds, ( Ati speed step), and i was getting terrible prformance. My friends brother had the same exact problem as me, he was running a i7-920 at 4.0 on liquid, and 4870 quadfire on liquid, and he was getting terrible fps untill he reinstalled drivers and it worked, He told me to do it, I did, and mine also worked. Something about ATI speed step and crysis not getting along.


ALSO: I heard you say you were getting MW2. Don't, mistake. It blows, servers go down every other day ( today for example). Much better of with Bc2. Also, all the noobtubers realy realy piss me off.
March 10, 2010 2:43:13 AM

Hey there,

Crysis always performs like a dog IMO. I believe it was badly coded. People still use Crysis as "THE" yardstick for performance, but seriously there are newer/faster/better games to be played.

Rest assured on that resolution, MW2 and other titles run WELL on your specs. Enjoy!
March 10, 2010 3:24:23 AM

I'm having the same kinda problem under Windows 7. Under Vista I get a lot better FPS. IDK if it's drivers under 7 or what.
March 10, 2010 3:33:30 AM

MW2 is ok, definitely not as good as the first

Bad Company 2 is pretty awesome
March 10, 2010 7:47:44 AM

Thanks for the responses!

have tried 3 (or maybe 4) driver versions ranging from the original version supplied on CD with the GPU itself, upto the latest 10.2, and it was after downgrading from 10.2 to an earlier version (I forget which), that I briefly had the ~40FPS thing going on for all of 5 minutes!

Each time I uninstall a driver I do the following:

Uninstall the driver from Device Manager (selecting the delete the driver option)
Uninstall Catalyst
Reboot
Run Driver Sweeper
Run CCleaner
Manually delete the ATI folders from Program Files and the user's AppData\Roaming folder
Manaually delete the ATI registry entry from HKCU\Software
Run Auslogics registry cleaner
Reboot
Install Catalyst
Depending on the driver version, disable ULPS (which frankly seems nothing but a PITA).

I think I'm cursed to be honest! I ordered all the components at the end of December (to beat the VAT increase here in the UK on Jan 1), but the GPU was not in stock until early Feb. Then I had to RMA the mobo (CPU socket pins), had to set the RAM down from 2000Mhz to 1600 as the mobo doesn't seem consistently happy with 2000. And now all this Crysis/GPU/driver stuff.

Given I had the higher FPS for a few minutes and the history of the machine & faulty mobo, I have been concerned the GPU is faulty; it's only the 3DMark06 score which gives me hope it's actually OK and just something amiss with Crysis and/or drivers.

Guess I'll keep plugging on with different driver versions for now...

Thanks again!

Jim

March 10, 2010 4:38:05 PM

I would try manually setting your clock speeds in ccc and see what happens. Then maybe you will know if it is a speed step thing.
March 10, 2010 5:46:08 PM

Run with GPU-Z open in the background, it will monitor and record the temps and clockspeeds, perhaps, as others have said, Crysis is just not getting the GPU up to full speed.
March 10, 2010 6:21:04 PM

It's a well known problem that Crysis sometimes running you're cards at idle speeds. Happens to thousands of people.
March 10, 2010 6:21:28 PM

Thanks Guys,

I'll try those too!

Also looking at the latest BIOS & Drivers on the ASUS site (8.69). They are slightly older than the current ones I have (8.702.0.0) which I got from ATI. Guess that's worth a try.

There's also a BIOS update but that only applies to cards with a certain part number (...-C3CH80-A01-... ) so I'll need to yank the card out later to check that.

Love the avatar Coozie7! The sound of a Merlin is one of the most evocative noises on the planet! Can't wait for the Duxford airshows this summer.
March 10, 2010 7:54:48 PM

Hi again chaps,

I ran GPU-Z while I opened Crysis, loaded a saved game, ran about for a few seconds then quit. The GPU-Z definitely showed activity going on:

The peak values were:

GPU Core Clock MHz: 725.0
GPU Mem Clock MHz: 1000.0
GPU Temp: 51.0 (centigrade)
Fan Speed: 30%
GPU Load: 77%

Cheers!

Jim
March 10, 2010 9:39:55 PM

hunuok said:
Hey there,

Crysis always performs like a dog IMO. I believe it was badly coded. People still use Crysis as "THE" yardstick for performance, but seriously there are newer/faster/better games to be played.

Rest assured on that resolution, MW2 and other titles run WELL on your specs. Enjoy!


It was godly coded, seriously, MW2 doesn't even BEGIN to compare the graphics. MW2's trees' are flat textures on no collision panels over a trunk.
March 10, 2010 10:00:20 PM

yeh, I need 24AA and 16 AF at 1680x1050 before thins look decent.
March 10, 2010 10:12:06 PM

One thing that can make a big difference at times is to turn off Aero before you run Crysis.
March 10, 2010 10:44:30 PM

Thanks Bystander!

Sorry, I should have mentioned. Already turned Aero off.

Still no luck with the ASUS provided drivers and the latest version of Smart Doctor seemed to want the Vcore voltage set to 0.95. Increased it, and it was miraculously back at 0.95 next time...

Ho-hum!
March 11, 2010 2:17:43 AM

Try Game Booster, in Crysis gives me an extra 2-3 FPS.
Anonymous
April 18, 2010 11:53:50 AM

Bucks85th said:
Sorry! Posted before finishing...

According to the benchmarks, I would expect to be getting 40+ FPS but am averaging about 10 with all settings very high. I have tried none and 8x AA.

I have tried various driver versions and for 5 minutes on an older driver, managed to get about 40-50 FPS before the game crashed. Have not been able to get it since no matter what driver I try.

I have tried Crysis 1.2 and 1.2.1.

I have tried disabling ULPS.

I have tried in Vista compatibility mode.

I am getting a score of around 24,400 on 3DMark06 so I don't think anything is faulty.

Does anyone have any suggestions as to what the problem may be?

Many thanks in advance!


Hey there, first post here too
.
That problem happens to me too, here are my specs:

Motherboard: ASUS P6T Deluxe
CPU: Intel Core I7 930 @ 2.80 Ghz (didnt overclock)
GPU: ASUS EAH 5970 2gb ddr5 etc (same as yours, I think)
PSU: LCPower 14c 600W
OS: Windows 7 x64
RAM: 6GB 3x2gb Corsair ddr3 1600 mhz.

I have tried disabling ULPS, reinstalling drivers, updating DirectX, in Vista and XP compatibilty mode, and the I only get about 5-10 FPS. I have managed to play it at 50-60 fps like 4 times, and when I closed the program and started it again, it was faulty. I executed GPU-Z in background when playing it at idle speeds, and the maximum GPU load i get is 25% (in one core), when the core clock speed is set at 750 mhz, and memory clock speed is set at 4000 mhz. I don't think the graphics card is faulty; I think its a driver problem, but as I tried many driver versions, and CCC versions aswell, i dont know what to do next. Any idea?
Sorry for my bad English, Im from Spain =S
April 18, 2010 12:31:17 PM

Make sure you have Catalyst AI enabled.
Anonymous
April 18, 2010 5:50:24 PM

rofl_my_waffle said:
Make sure you have Catalyst AI enabled.


It is, and it's set to "Advanced"
April 19, 2010 1:51:58 AM

You should be able to get a decent frame rate with that system. I am able to run Crysis maxed out at 1600x900 no AA on my laptop @ 30-35 fps. A desktop should obviously run it even better.

i7 720QM
8GB RAM
ATI 5870
April 19, 2010 2:22:39 AM

Uninstall the Asus software and give that a try. I've had nothing but trouble with their SW in the past.
April 19, 2010 4:43:38 AM

Someone in a different thread had a problem with his 5850. Apparently turning off "Alternate DVI operation mode" helped his futuremark score. I have no idea what it is about but maybe you need some of that.

You can find it in CCC>Desktops & Displays>Configure>Attributes
April 19, 2010 12:10:16 PM

Yeah, I saw that too in another thread. I need to do some tests to see if I can tell any difference.
Anonymous
April 24, 2010 2:30:24 PM

Allright. Managed to fix it. It was the operative system; seems that ATI drivers donĀ“t support Windows 7 RTM build 7600. I installed Vista Ultimate and it runs perfectly around 40-50 fps with 8x AA and 2x AF. Thanks for your help ppl!
Anonymous
April 24, 2010 2:31:10 PM

I am "anonymous" :D 
!