Sign in with
Sign up | Sign in
Your question

I5 750 poor performance

Last response: in Systems
Share
March 25, 2010 7:16:41 PM

Hi Everyone.

I just yesterday put together an I5 750 with 4gb of ram, a 750gb wd black hard drive and my old 8800gtx on an asrock H55DE3 motherboard. Everything is running at stock timings but my crysis cpu2 benchmark is a dismal 20-22fps!

My i7 920 on an asus p6t deluxe v2, 300gb velociraptor, 6gb ram and that same 8800gtx gets 58 fps at the same settings.

Anyone have any ideas as to why this could be happening? I hope its not a bad motherboard.

More about : 750 poor performance

March 25, 2010 8:58:26 PM

Do you have your video card in the pcie x4 slot instead of the x16 slot? Prob. a dumb question.
m
0
l
March 25, 2010 9:00:24 PM

according to the manual either slot is 16x if there's only 1 gpu present. I have mine in the top slot
m
0
l
Related resources
March 25, 2010 9:11:50 PM

What resolution are you trying to game at?
m
0
l
March 25, 2010 9:17:04 PM

10x7 very high quality dx10. Not that that should matter since im running a comparative analysis on the two systems and all the benchmark reviews Ive seen put the 750 at or above the 920... but im getting half the performance.
m
0
l
March 25, 2010 9:18:43 PM

What are your idle/load CPU temps? It's possible the CPU is overheating and throttling. Did you do a fresh OS install on the system?
m
0
l
March 25, 2010 9:28:57 PM

idle 33-38
peak 52-58

Pretty good for the stock intel cooler and some thermalright chill factor2 I'd say.
m
0
l
March 25, 2010 9:34:12 PM

Well, knowing the resolution helps us know what performance you should expect, so thanks for posting that.

Any chance this is an i5-750S, not a regular i5-750? Tom's had an article about the S versions lower performance.
m
0
l
March 25, 2010 9:40:59 PM

@branflakes: I did read that article but according to cpuz its a standard 750.
m
0
l
March 25, 2010 9:43:26 PM

Check CPUZ for what it says the vid card is running at...x16 or x4 or x8?
m
0
l
March 25, 2010 9:48:31 PM

says linked with 16x max 16x
m
0
l
March 25, 2010 9:52:10 PM

So far so good. What the card's temps under load? Are you using the same drivers in both setups?
m
0
l
March 25, 2010 9:55:47 PM

well not anymore the drivers on the 750 just came out. my 920 drivers are in the 192's vs the 197.13 on the i5.

Card Idles at 60 peaks at 83
m
0
l
March 25, 2010 10:12:29 PM

Have you thought about running a passmark.com bench test on it? A good way to see where your bottle neck is and allow you to compare your system to others of a similar build.

I used it when tweaking my new build and was fairly happy with the data it gave me.
m
0
l
March 25, 2010 10:12:36 PM

So, you did originally run the 192 drivers and same results?

How about a BIOS update on the board?
m
0
l
March 25, 2010 10:18:54 PM

@brent: hey fellow NC'er he he he. Id not heard of passmark or at least paid any attention to it in the benchmarks ive seen (usually just looking for game perf.)

@branflakes: no but I can go download them from guru3d if they are still there. Tried updating the bios but the one bios thats available on their site doesnt want to install for some reason. Its an "instant flash" only install and I put it on a floppy and rebooted (rebooted? is that even a word?) It sees the floppy but doesnt see the bios file on it and there's only 3 files on it so its not hard to find LOL.

The guy from asrock told me to compare apples to apples when doing a comparison since the 750 only does dual channel ram and the 920 does triple channel and the 750 doesnt have HT. So I sent him the toms comparison chart that showed the benchies from the two where the 750 was almost identical to the 920 in just about every benchmark and informed him i was getting 20 fps not 120. He has yet to reply.


[edit] sorry I just checked the txt file I wrote up when I did my benchmark test on the 920 and I was using 182.08's on vista business 64bit. So I got those drivers and uninstalled my 197.13's and restarted. Installed those and re ran the bench... no difference.[/edit]
m
0
l
March 25, 2010 10:31:54 PM

I would definitley work on getting that bios update in . Do you have a usb stick, I'm pretty sure you can have it on there. Then within the bios itself theres a option to update bios. It looks for the file on a fat32 drive. Thats why the usb stick.
m
0
l
March 25, 2010 10:34:20 PM

Yeah I tried on both a usb and a floppy and it couldnt access the file on either.
m
0
l
March 26, 2010 2:07:03 AM

are you booting of the USB/FLoppy with the BIOS image? If you're getting a "Invalid boot Partition" or "No Boot Partition Detected" or something like that, you're doing it wrong.

How to start the flash process differs by board, but this should work:

Start PC
Enter BIOS
Look around, somewhere it might say "Press F8 for BIOS Flash Utility" or something if not, start looking through the menus to see if anything resembles a bios update.
If you find it, within the utility, navigate to your USB/Floppy drive and perform the flash.

If you really can't find it.... you need to create a boot disk go boot into dos... please try the steps above first.. flashing by dos is annoying and i don't want to list the steps unless i absolutely had to...
m
0
l
March 26, 2010 2:12:46 AM

thanks Weilin but it doesnt give you the option to navigate. It has a split screen with the devices on the right and the applicable bios' on the left.

I downloaded the file, copied it to a freshly formatted floppy (in an external usb floppy), restarted, went into bios, went to the chipset portion, at the bottom it has the instant flash utility (or i could have hit F6 to get to the instant flash instead of F2 to get into bios then navigating to the instant flash), run the instant flash utility and it scans for devices (usb/floppy and hard drive) for the files that match my motherboard's bios. It finds my floppy but it says that there's no matching file. Same procedure for the usb stick with the same result.
m
0
l
March 26, 2010 3:30:13 AM

Ok nevermind Im a moron. When I benchmarked my 920 I didnt write down that I did it in dx9 mode. When i took the vid card out of the 570 and put it back in the 920 and ran the benchmark at the same specs but on dx10 I get 20-22fps there too. Still dont know why it wont let me install the stupid bios update but at least I know Im not dealing with funct up hardware.
m
0
l
March 26, 2010 10:41:48 PM

glad to hear everything is "works" As for the bios... I have no idea why the floppy doesn't work... but for USB key. make sure the USB key is formatted to FAT32... the BIOS can't read NTFS partitions... I spent a long time fighting with a Gigabyte board because of this...
m
0
l
!