Sign in with
Sign up | Sign in
Your question

Hd 5970 display crash

Last response: in Graphics & Displays
Share
March 10, 2010 3:56:26 AM

hey guys, just finished my first build. this is the rig.
coolermaster HAF
1200 watt supply
asus m4a79t deluxe
phenom 2 550 unlocked
corsair 1333 8 gigs
powercolor hd 5970
7 ultimate 64
here is the problem: clean install, load display drivers off of provided disc, and it restarts into a new res. so far so good. within 5 min., screen starts to pixelate and message reads <display driver stopped responding and has recovered> does that about 3 times and shuts down into bios and get this message<hypertransport sync flood error occured> after this happens i get BLUE SCREEN. after reboot it goes to blue screen immediatly after windows loads. this is my 3rd card thinking i have been shipped bad ones. i did a little research into HT flood errors and it i think it has to do with low voltage to the cpu?
LOL, i gave up and took it to geek squad and they have no clue! that cost 70 bucks. i know this motherboards been out a while, so you guys think maybe the bois is outdated or should i try installing catalyst 10.2 drivers? please help, my wife found out how much i spent, and the damn thing doesnt even work. thanks for any help Josh

More about : 5970 display crash

March 10, 2010 6:22:28 AM

1. Please post the temps of the card by using GPU-z.
2. You said that this is the 3rd card you RMAed? Seeing this it might not be the cards fault.
3. Lock the CPU core and try without any OC.
4. Run a program like Memtest to check for memory issues.
5. Run a program like Prime95 to check for CPU stability.
6. Install the latest ATI drivers.
March 10, 2010 8:06:33 AM

Hello and welcome to the forums :) 
There are many users with this pixelated display problem and other 2D problems with HD 5970 but i think newer drivers will help,however there is a fix and its that you have to set your 2D clocks to 400/900 (its 157/300 by default) and here is how:

1_Open CCC and choose Overdrive tab,unlock the settings(by clicking on the " Gold Key" icon)
2_Go top options,profile and choose profile manager.
3_In the composition tab,choose "The following settings" and in the "ATI Radeon HD 5900 series"make sure only ATI overdrive is checked.
Then enter a profile name,then save and close it(Do not activate).
4_Go to C:\Users\Your UserName\AppData\Local\ATI\ACE\Profiles (Its hidden so make sure you unlock hidden files and folders)
5_Open the profile with wordpad and do this edits:
<Feature name="CoreClockTarget_0">
<Property name="Want_0" value="40000" /> (default is 15700)

<Feature name="MemoryClockTarget_0">
<Property name="Want_0" value="90000" /> (default is 30000)

and for the second card:

<Feature name="CoreClockTarget_1">
<Property name="Want_0" value="40000" />

<Feature name="MemoryClockTarget_1">
<Property name="Want_0" value="90000" />

Save the changes and close.

6_Open CCC,in options tab go to profiles,profile manager and choose the profile that you saved before and then click on Activate and close.

Now your cards will idle @ 400/900 and you should not experience any more problems in 2D mode.
Related resources
March 10, 2010 3:47:03 PM

thanks for reply, i cant get into the ccc fast enough without getting blue screened.
March 10, 2010 3:49:51 PM

is there anyway to get into catalyst center in a "safe mode" before system nosedives?
!