Sign in with
Sign up | Sign in
Your question

Only 4 of 6gb recognized

Tags:
  • Memory
Last response: in Memory
Share
November 28, 2010 2:44:20 PM

After a rocky start getting my system up and going (The layout of my mobo for memory is 2-1-2-1-2-1 as opposed to the opposite, which is what I assumed; quickly remedied) I started it yesterday morning to see that it was booting up normally. It showed all 6 gigs of the three sticks of 2gb Mushkin DDR3 triple channel RAM I had. This was good, but it was right before work.

When I got home from work only 4gb out of the 6gb was recognized, even before I put in the OS DVD. Simply glad to have a working computer, I spent the evening installing things and downloading motherboard updates.

Today though still only 4 gigs shows up; one stick isn't being recognized. I booted from a flash drive holding MemTest86+ but sadly the testing was too slow to get through in the 10 minutes before work. What I did notice was that it showed a 2 gig stick in three slots, totalling the normal amount 6gn. However it only reported 4gb in memory.

I can't imagine it's damaged or broken as nothing really happened to it that didn't happen to all the other pieces.

Not really sure how to proceed. Nothing really happened between the times that it recognized 6gb and when it dropped to 4gb; I just bunched up the cabling that was hanging out and closed the case up. I'll run MemTest86+ this evening in full, but it doesn't seem to recognize all 6 gb anyhow. How can I proceed? Should I start removing 1 stick at a time to locate the offender, and try and find another system to test it on? Anything I can do to get the system to pick it up again?


System Details:
Intel Core i7 950
Asus P6X58D-E
Mushkin Blackline 3x2gb 7-8-7
Corsair TX750W

More about : 6gb recognized

a c 347 } Memory
November 28, 2010 2:57:22 PM

Please verify:
{CPU} | A2 | A1 | B2 | B1 | C2 | C1 | ; A1/B1/C1

Yes, you can test 1 stick at a time test in A1, but also test the DIMM slots them selves use A1 DIMM then -> B1 DIMM then -> C1 DIMM

What Mushkin model Tri Channel Set do you have?

This a common occurrence, most of the time it's from a poorly seated DIMM {don't baby them into the slots}, other common problems include: Partitions, 32-bit OS vs 64-bit, bent CPU Pin, Incompatible RAM, etc.

If possible please post the following:


Verify the following:
November 28, 2010 3:29:16 PM

Confirmed on the DIMM channel diagram. Threw me for a loop but they're currently in A1 B1 C1. I've also tried swapping and reseating B1 and C1 numerous times, and firmly.

This is the RAM in question.

No partitions (OS on SSD, plus a secondary larger HDD), and everything relevant is 64-bit. The issue showed up shortly before I even installed an OS though.

I'll post the other info requested when I am home and able to.
I'll also check if it's a slot vs. stick issue.

Thank you for the continued assistance. :) 
Related resources
a c 347 } Memory
November 28, 2010 4:24:56 PM

I have read issues, you can see them as well, with 'bad' sticks. But this may be a setting and voltage issue.

Q - When you startup does the MEMOK turn 'on' or stay 'on' ? If so you can use the MEMOK button to set the RAM ; see page 2-24.

Otherwise, boot into BIOS:
Ai Overclock Tuner = Auto
DRAM Frequency = DDR3-1600 MHz
DRAM Bus Voltage = 1.65v
QPI/DRAM Voltage = 1.4v
DRAM Timing Control Enter {7-8-7-20}
DRAM CAS# Latency = 7
DRAM RAS# to CAS# Delay = 8
DRAM RAS# PRE Time = 7
DRAM RAS# ACT Time = 20

Depending on your RAM, you might need:
Ai Overclock Tuner = Manual
DRAM Frequency = DDR3-1600 MHz
DRAM Bus Voltage = 1.65v
QPI/DRAM Voltage = 1.4v
DRAM Timing Control Enter {7-8-7-20}
DRAM CAS# Latency = 7
DRAM RAS# to CAS# Delay = 8
DRAM RAS# PRE Time = 7
DRAM RAS# ACT Time = 20
November 29, 2010 3:02:49 AM

I believe that did the trick, jaquith. :)  The MemOK! light never turned on after I found the proper slots, and pressing it did nothing of use.

Followed the directions to a T (Was going to adjust the RAM timings anyhow, but as for the rest I admit to this being by first build taking RAM timing into account) and now all 6 gigs are showing up.

Thank you very much for the help; this was the last little quirk in what has been a slightly bumpy build. :) 
a c 347 } Memory
November 29, 2010 11:33:32 AM

Cool! Glad to hear! :sol: 
November 30, 2010 12:04:40 AM

Sadly, a collapse in good luck today. Only 4 gigs recognized again. I double checked to see if the settings had changed was somehow reset, but they persisted.

The remaining issues on this machine seem to be this and being unable to apply Windows 7 updates on restart (Waits at 0% for a few minutes before giving up and uninstalling the updates. Does this every time I don't tell it to not install anything).

In a moment I might try swapping out sticks and ports to see if a particular stick is at issue. Resource monitor only shows 4 gigs.
a c 347 } Memory
November 30, 2010 12:35:09 AM

:(  Okay - Try pulling the RAM and clean the contacts with Isopropyl alchol and place in the DIMM slots damp; repeat the process twice for each DIMM/RAM used. The DIMM pins often have production oils.
November 30, 2010 3:42:03 AM

Testing concluded that... nothing is wrong. :/  Tried each slot with one stick and then each individually, and nothing pointed to an error or broken piece. Then I put all three sticks in and they were recognized.

Didn't learn a whole lot from that; already knew that there wasn't one slot or stick that was definitively dead. Only thing I can attribute this to is that before each time that I got all 6gb I had had the PSU flicked off for a time. I suppose I'll watch that, as I've no other leads at the moment.
a c 347 } Memory
November 30, 2010 11:51:14 AM

Sonic Flash said:
...Only thing I can attribute this to is that before each time that I got all 6gb I had had the PSU flicked off for a time...

If your PSU is bad or going bad then you can have all sorts of 'oddball' behavior. The RAM needs sufficient power or the DIMM won't have enough power {stable power} to keep 'on' and the BIOS will turn-off the RAM. Often the 'last' DIMM slot is the 'effected' one.

Changes:
DRAM Bus Voltage = [1.65v]
QPI/DRAM Voltage = [Auto or 1.35v~1.40v] ; try all 3

Failure add the following:
Xtreme Phase Full Power Mode [Enabled]
December 1, 2010 12:07:50 AM

This morning I had briefly flicked off the PSU, and afterwards 6gb were discovered. I also went ahead and made the changes listed above. Upon coming home from work (It spends the day turned off, but the PSU is still on) it detected 4gb. I double checked the settings and they all persisted; detecting 4gb.

Is it possible that one of the sticks of slots needs to be power drained by manually turning off the PSU? I admit this makes little sense...
a c 347 } Memory
December 1, 2010 12:21:45 AM

I hear you...but if you made the changes and did the things I suggested -- anything more is beating a dead horse.

Exchange for Corsair TR3X6G1600C8D I have 10 sets 0 problems!
December 1, 2010 5:11:37 AM

Hmm, Your bet would be for the RAM being the cause of this?

Wish I had a second system that ran DDR3 around to test that out, but I might have to resort to a local PC place just to confirm it isn't a RAM slot or something. Not sure how likely that is.

Thanks for all the help. :) 
December 1, 2010 11:18:10 AM

I had the same problem before
the RAM worked just fine after a little clean up :) 

a c 347 } Memory
December 1, 2010 1:11:37 PM

^Already recommended "Isopropyl alchol alcohol" even though I just noticed my dumb spelling mistake.
December 1, 2010 2:00:55 PM

I actually found some isopropyl in the bathroom under the sink (which is oddly coincidental).

As per instructions I have rubbed down the triplets and put'em away damp. We'll see if all of them show up later.
a c 347 } Memory
December 1, 2010 2:13:22 PM

^let them dry ~15 minutes before powering on. The connectors during Mfg process are covered in oil to prevent tearing; they're 'supposed' to be cleaned before they are installed to the MOBO...
December 2, 2010 12:12:37 AM

No dice, sadly. 4gigs reported on start up.

I ran CPU-Z and it reported 6 gigs, with all 3 slots reporting exactly the same.
Meanwhile the monitor widget on the desktop reports 4 gigs.

What could a discrepancy like that suggest?
a c 347 } Memory
December 2, 2010 12:32:45 PM

If you had a P55 MOBO then my initial reaction would be a bent CPU pin. If you 'really' think of the total number of 'pins' for both the RAM and CPU it makes your head spin.

'IF' you're up to it -> pull the CPU look VERY carefully examine pins for alignment.

'Seeing' the memory and 'Accessing' the memory are two entirely different concepts. Keep in mind: 1. BIOS has to 'see' the Memory {DIMM connections}, 2. BIOS has to accept/test the memory {timings, voltage, etc -> Kit Matching}, 3. CPU needs to process the memory via it's memory controller {all pins}.

If the CPU turns-out to be okay then:
Load Defaults
Ai Overclock Tuner = Auto
DRAM Frequency = DDR3-1600 MHz

If failure send the RAM back in and exchange. Memory is so fast, has so many billions of bit of data storage, and is so 'touchy' -> CAS 7 = 7/1,000,000,000 of a second. Perhaps the set matching, BIN sorting, at Mushkin was a little off.

RE: "What could a discrepancy like that suggest?" -> See above.

Good Luck!
!