Reformatting Problems: NTOSKRNL/Intel ICH10r

Hi Guys,

Another issue about my setup here. I'm trying to format and reinstall Windows XP x64 on my hard drives at home and I'm getting the following error below:

Windows could not start because the following file is missing or corrupt:
<Windows root>\system32\ntoskrnl.exe
Please re-install a copy of the above file

I just formatted maybe 2-3 months ago and had NO problems at all using practically the same setup.

I have tried all three of my separate hard drives as well as a different Windows XP disk and I STILL get this error, so I don't think it's that hardware. I've scanned the disks using WD Tools, I've gone into recovery mode and ran FIXMBR and BOOTCFG. No luck. Have ran chkdsk. I've had tons of problems doing basic things on this mobo since I got it and this is just the latest. :fou: :fou:

My setup is like follows:

EVGA Intel X58 Mobo

Intel ICH10R on AHCI

WD Raptor 1
WD Raptor 2

I HAD XP on Raptor 1 and Windows 7 on Raptor 2 - I would like to do the same now, but anytime I get into XP setup I inevitably get to the ntoskrnl.exe error.

I noticed Windows 7 wrote a BOOT info folder to my XP disk, even though I have formatted multiple times could this have anything to do with it?
6 answers Last reply
More about reformatting problems ntoskrnl intel ich10r
  1. Does that particular XP disk "belong" to that mobo ??

    = Al =
  2. That, or do you have a bad stick of RAM in there? I'd run a memtest if you're getting missing/corrupt files at all.
  3. I'm not sure what you mean, if it "belongs"? On the two raptor drives, I've only ever used this Windows XP x64 or the Windows 7 x64 install discs.

    I'm really thinking that perhaps it has something to do with the fact that Windows 7 installed to drive B, but wrote boot information to drive A? I'm not sure - have done several formats on each and I thought that would've erased everything.

    I don't think a bad stick is likely, but I will try that tonight and see how it goes.
  4. OEM windows is tied to a mobo serial# ... once validated ... tied for life.
  5. I've let Memtest run for 6 hours/5 passes and no errors at all.

    I tried using the Windows 7 disk to format vs. the XP and I get the same thing. Afterwards, I reset my BIOS settings and now I get:


    "Windows could not start because of a computer disk hardware configuration problem. Could not read from the selected boot disk. Check the boot path and disk hardware"

    I'm out of ideas... This is a 2 month old MOBO so I wouldn't think there would be any problems with it.
  6. OK, well, I finally, finally got this - sort of.

    Instead of AHCI I put the controller into RAID and got it to work. So obviously something is wrong with AHCI mode, but I just can't figure out what...
Ask a new question

Read More

Homebuilt Hard Drives Windows XP Systems