Sign in with
Sign up | Sign in
Your question

Problem with my ssd

Last response: in Storage
Share
April 27, 2012 12:34:35 AM

hi,im having a strange problem.before 2 days my pc crashed with no reason and i couldnt boot with my ssd saying that a file is corrupted or something(i got 1 ssd and 1 hdd having my files).then i opened the case and i cleaned up everything inside.then i thought a format could help me but my i couldnt install windows in my ssd.i installed windows in my hdd and this is happening.my ssd is like 2 drivers which i cant open them doesnt show how many storage they have.they are just nothing.
http://imageshack.us/f/171/72173087.jpg/

my bios reads ssd,i installed programs like ssd-life and lots of others and all saying that my ssd is healthy.so i guess its bios problem.and since i cant spend like 30 euros to fix it im looking for a possible solution.please if anyone could help,i can be here for like 4-5 more hours and i can provide every photo of my bios,plus teamviewer

More about : problem ssd

April 28, 2012 1:21:59 AM

bump ;/
a c 99 G Storage
April 28, 2012 1:45:52 AM

Booting to the HDD windows, run DISKPART to do a CLEAN function to the SSD, then shutdown the PC, then unplug the HDD, set boot order in BIOS to SSD then DVD, reboot to DVD, and try to install to the SSD.

Let me try to tell you how.

Once booted up in Windows, do these commands:

start\in the search box, enter "cmd", right click on cmd, run as admin;

Input as follows: DISKPART, LIST DISK, SELECT DISK 0 (if 0 is the SSD), CLEAN, EXIT, EXIT.

If you get here, you should be able to shutdown, unlpug the HDD, restart, set boot order, and boot to the install DVD. If Windows install sees the drive, you should be good to go. After WIndows is all installed, shutdown, and plug the HDD back in. Then delete all the Windows stuff from the HDD, that wasn't there before you installed to it. KEEP the files that are yours!

Cheers.
Related resources
a c 88 G Storage
April 28, 2012 2:07:31 AM

Hi Elias,

You can do what Foscooter said but I'm going to recommend a better way. SSDs have the ability to completely erase themselves and reset to factory defaults. To do this, I suggest that you use a recovery CD called PartedMagic. PartedMagic contains an erasure program which has the ability to utilize the "Secure Erase" function on SSDs.

Here's a quick guide:

http://howto.cnet.com/8301-11310_39-20115106-285/how-to...
a c 99 G Storage
April 29, 2012 5:45:29 AM

Great suggestion Pinhedd. And great rig you have!

I have, and use the same thing on a Boootable USB Linux device, which I "got" from the OCZ Toolbox Guides.

However, the reason I suggested what I did is not everybody has the ability to do this: download, create and use a bootable USB/CD when they have problems like these.

The CLEAN command in DISKPART just "erases" the MBR and all the partions. This makes the drive appear to be blank, when it actually isn't. The CLEAN ALL command wipes the drive with zeros, but this is bad for a SSD.

The main thing about DISKPART is: it is part of the Windows install disk, when trying to do a recovery/diagostics. So most people will have access to it during an install, as well as when Windows is up and useable, as it's a command line tool.
April 29, 2012 7:17:14 AM

hello everyone and thans for the suggestions,but unfortunately it didnt worked.i used parted magic,burned the iso to one cd,boot from the cd,did the erase thing(i checked 2-3 youtube videos aswell to be sure what i have to do)and still nothing.cant install windows in the ssd.the error is the same again...
'Windows could not format a partition on disk 0. The error occured while preparing the partition selected for installation. Error code: 0x80070057.

If I try and click the format link before going to the next step, I get:

Failed to format the selected partition. [Error: 0x80070057]. '
i dont know whats going on.im uploading a video showing you guys my bios setup and let me know if anything there is not in the way it should be.
a c 144 G Storage
April 29, 2012 4:16:38 PM

In the SATA configuration, you need to set to AHCI instead in the video you set up IDE
a c 88 G Storage
April 29, 2012 4:52:31 PM

What cin19 says is correct. There is no reason to be in IDE mode anymore and this will cause tons of problems for SSDs, use either AHCI or RAID (RAID uses RAID for RAID member disks and AHCI for non-member disks so it will work fine as well)
April 29, 2012 5:29:02 PM

hello and thanks for the sugestions,BUT still nothing.i changed bios sata configuration to ahci,plus on chip sata2 controll to ahci and still nothing.i booted again with partedmagic and erased the disc.booted back with windows cd and i have a new error...
http://3.bp.blogspot.com/_A3o0EjLYCNg/SErcJWk1fvI/AAAAA...
this one.so it must be something else,damn it :/ 
a c 144 G Storage
April 29, 2012 6:37:10 PM

like Foscooter said unplug the HDD, set boot order in BIOS to 1st SSD then DVD, reboot to DVD, and try to install to the SSD.

If it not work, then try to install the Window in WDC_HD.

If all are not work then i have not idea. Sorry.

a c 144 G Storage
April 29, 2012 7:35:19 PM

I watch your video again, and i found that will be the problem: in the Advances Setup window, that only show 1st boot "DVD", 2nd boot "DVD", and 3rd boot "removable Dev". When you move down to the 1st boot DVD and it show up WDC, DVD but not SSD.

Try the SSD in other PC to see it work or dead. Because the ist error code 8004345F is related the HD.

So update the BIOS, unplug the WDC HD, boot into BIOS, set the AHCI, then set 1st boot "DVD", 2nd boot "SSD", try this to install the Win.
April 30, 2012 6:16:46 PM

hi and thanks for the suggestion,but still nothing.i unplugged hdd,made like 30 restarts playing with bios(like 1 option ahci 2nd ide,1st ide second ahci and so on),and every time says that windows cannot install blablabla..im start thinking that i have to buy a new ssd ;/
a c 99 G Storage
April 30, 2012 6:52:28 PM

Yeah, it appears to be the SSD.

If after all the "fixes" we suggested:

Secure Erase the SSD
Unplug the HDD
BIOS set to ACHI
BIOS boot priority to DVD 1st, then SSD

And you still can't install......:( 
a c 88 G Storage
May 1, 2012 12:09:44 AM

Do you have any USB mass storage devices plugged in? The Windows installer can be very buggy sometimes
May 1, 2012 1:14:26 AM

no,only the keyboard and the mouse :( 
a c 88 G Storage
May 2, 2012 6:38:34 PM

Have you checked to see if the SSD is at the latest firmware? Usually this won't prevent you from installing an OS to it but I've seen a few which go bonkers. If that fails, it's time to RMA
May 22, 2012 5:38:27 PM

I had this exact same issue... After hours of trial and error, I switched the drive from a SATA 3 port to SATA 2, and it worked perfectly.

//edit: Not a member, but stumbled upon this while I was researching the problem myself. Here is my rig for those it might help (and maybe to help google searchers)

CPU: Intel Core i7-3770 3.4GHz Quad-Core Processor
Motherboard: Gigabyte GA-Z77-D3H ATX LGA1155
Memory: Mushkin Blackline 16GB (4 x 4GB) DDR3-1600 Memory
Power Supply: Rosewill 530W ATX12V / EPS12V Power Supply
Hard Drive: OCZ Vertex 3 120GB 2.5" Solid State Disk (SSD)
May 24, 2012 3:36:49 AM

hi,i gave the ssd to the shop i bought and they gave me this ssd
http://www.ocztechnology.com/ocz-vertex-3-sata-iii-2-5-...
thanks everyone for the help but it seems that the disc was dead.

now my problem is how will i delete the 'windows' folder in the hdd i used to have windows.im searchin google but cant find anything usefull.hope anyone can help while im keep searchin
May 29, 2012 9:25:02 PM

Well..... Long story short... The drive was working well enough on the SATA 2 port, but every now and again (maybe every 1-2 hours), it would lapse for like 5 seconds, then go back to working properly... I wouldn't have noticed if I wasn't gaming, and had hardware monitors running on the second screen... There was also 2 times (out of, say, 100) that it failed to initialize on boot even on SATA2 (restarting the computer fixed it though).

Anyways.... I ended up RMA-ing the drive with OCZ (whose customer service, by the way, is surprisingly good [800-459-1816 x411 for a live person]). The new drive came in, and it installed flawlessly, without any problem... And the new drive is running great.

So... If anybody else out there sees this, and has the option, I would call and get your drive replaced.

Otherwise... Try the port switch, or try updating the firmware to 2.22, and see if that helps (note, you will need to do that on a separate PC)

http://www.ocztechnology.com/ssd_tools/

I'm very unlikely to check back in here, but best of luck to you on getting this fixed.
!