Sign in with
Sign up | Sign in
Your question

OCZ Agility 3 120GB, worked for one day!

Last response: in Storage
Share
April 27, 2012 5:53:12 AM

I recently purchased a brand new OCZ Agility 3 120GB SSD Drive online and received it in the mail yesterday. I installed it as my third hard drive and instantly it worked perfect, showed up in windows and everything was good to go. I turned off my PC last night, turned it back on this afternoon, and now the drive doesn't show up in windows or bios. I've searched the internet for possible solutions, and most of them say to update the firmware on the drive, but I can't do that because it's not even recognized anymore. What would have caused this? I don't understand how it works one minute, and fails the next. I have the OK to return the drive for a refund but I want to make sure I haven't missed anything. I've tried different cables, sata ports, switiching between ahci/ide modes, plugging it into 2 other computers and nothing. I'm running it on an ASUS P8Z68-V Pro motherboard.

Thanks for any help!
a b G Storage
April 27, 2012 7:39:03 AM

Welcome to the club dude!
I sent back a couple OCZ disks myself (Vertex2), untill they sent me an Agility3, which has been running a few months now without issue.
On the up side, OCZ has a good RMA department, you will probably get a replacement within 10 days.
If you can get a replacement from where you got it, I would go with another brand!
April 27, 2012 3:12:48 PM

I bought it brand new from someone on ebay, but he has no problem refunding me once I ship it back. I think I might go with another Corsair Force drive, as I have a 60gb right now as my OS drive from them and its worked great without problems. I got a good deal on the OCZ which sucks now that I have to send it back! lol
!