Error Code 31, cant get online.

I have a built computer and I cant seem to connect online. This problem happened after I kept unplugging in and out the ethernet cable. could I have damaged the ethernet port?

Is it possible to break that part of the motherboard? Anyway to fix this or am I sol and need to get another gigabyte mb? Anyway to check?

My built computer for some reason cannot connect online. I'll post as much info as possible.

Motherboard: Gigabyte EP45-UD3P
OS: Windows 7 64bit

Tried the wizard and trouble shooting and still wont fix the problem. I've got:

The diagnostics policy service is not running.
Code 31

I checked the hardware and driver for possible fix. Got error:

Microsoft Teredo Tunneling Adapter
Realtek PCle GBE Family Controller
Realtek PCle GBE Family Controller #2
WAN Miniport IKEv2
WAN Miniport IP
WAN Miniport IPv6
WAN Miniport L2TP
WAN Miniport Network Monitor
WAN Miniport PPPOE
WAN Miniport PPTP

I went to the gigabyte website to try and install possible new drivers and didnt work.

Is my motherboard the problem? Is the hardware fried? Could uninstalling the driver fix this? Help lol.
5 answers Last reply
More about error code online
  1. Well there's a few ways to resolve this:
    1. Easy - try Restoring to an earlier last know good registry.
    2. Easy - Open the Device Manager expand the [+] Network Adapters ; right-click Uninstall and restart.

    3. They get harder after that.
  2. First, it could be a virus or other malware. You would know if your usage pattern exposes you to malware. Here's a list of things you could do (if you can get on line somewhere lol):

    http://www.tomshardware.com/forum/8263-63-simple-free-guide-removing-malware

    If the error code is real, this approach may help:

    http://pcsupport.about.com/od/findbyerrormessage/a/code-31-error.htm

    Hope this helps.
  3. ^ Did you 'read' that link? {C 31}

    My assumption is the registry got corrupted. If in 'some' rare instance you have a 'virus' use the ESET online scanner -> http://www.eset.com/online-scanner
  4. My Ga-EX58-UD3H-SLI board had the same problem. The integrated lan would just stop working. I tried 2 PCI lan cards and both were supposedly fast 10/100/1000 cards but they were so slow compared with the integrated lan when it was working. The first time I was told that I should reinstall windows Vista Home Premium 64-bit as a last resort and it worked. The 2nd time it happened, I had the comp apart and left it on a bench over night completely unhooked to power and etc. Something told me to try it the next day and it worked and I had not changed anything. Thinking maybe it's static electricity??? Don't know. The 3rd time I made the mistake of letting windows update, update the lan driver. I downloaded the new update with another comp, uninstalled the lan driver thru device manager and then installed the new driver and it worked again. Since I have updated the lan, chipset and bios too, all to the newest (not beta) versions and it's been a year or so since the lan has quit. I'm a happy camper now!
  5. Thanks everyone for the reply! I will attempt to try all suggestions posted above and will report back promptly tomorrow. Thank you!
Ask a new question

Read More

Gigabyte WAN Motherboards