Sign in with
Sign up | Sign in
Your question

Not sure what went wrong...

Last response: in Systems
Share
March 27, 2010 2:01:47 PM

Yesterday i was on my CyberPower PC gaming PC and the screen went black... I was just browsing through facebook and the screen went black! I am not sure what exactly to do. My computer wont really turn on. It will turn on but then the screen goes black and my monitor Power light keeps blinking as if there is nothing even plugged in... Any ideas? Need this to be fixed sooon!!!

Thanks

More about : wrong

a b B Homebuilt system
March 27, 2010 2:08:02 PM

Full system specs. You said its from CyberPower, is it still under warranty?

First thing to check, is everything still plugged in properly? Unplug the cables and plug them back in on both ends. Also try using a different monitor thats known to work or try the monitor on a different computer to rule out the monitor as the source of the problem.
March 27, 2010 2:13:30 PM

Full System Specs:
CPU: AMD Athlon II X2 240 Dual Core Desktop Processor
RAM: 4GB PC2-6400 DDR2 Memory
HDD: 500GB 7200rpm SATA Hard Drive
CD-ROM: 22x DVD+/-RW Dual Layer Burner
GPU: ATI Radeon HD 4550 Graphics Card With 512MB Memory

I have plugged everything back in and no luck. I have also tried to hook it up to my tv which has previously worked, and no luck. Does not even register that there is anything plugged in. Could this be a faulty cord?
Related resources
a c 122 B Homebuilt system
March 27, 2010 2:24:13 PM

And if none of the simple stuff works, and the system is still under warranty, return it.
March 27, 2010 2:25:33 PM

I am not sure if it is under warranty though, i bought it off of newegg. Any way i can check?
March 27, 2010 4:37:58 PM

Any solutions to this? I got to safe mode 1 time. Now it wont go back
!