Sign in with
Sign up | Sign in
Your question

Not enough system memory?

Last response: in Memory
Share
December 1, 2010 12:18:06 PM

When playing Civ 5 at 1920x1080 highest settings loading leader screens, map scrolls and switching to another program all take quite a long time. I'm also getting artifacts on the screen. CPU and GPU usage are never at or near maximum. The page file is being heavily used with the HDD going crazy whenever I try to talk to another leader and resource monitor is showing around 3gb RAM in use and 1gb on standby. I suspect this can be resolved by buying another 4gb RAM but before spending my money I wanted to confirm that it is the amount of RAM that is my limiting factor and not the RAM speed or anything else, like only 512mb video memory (cross fire).

I always thought 4GB RAM was enough, but maybe not anymore. Full specs:

Q6600 @ stock
Asus p5q pro
HD4850 512 mb CF
4gb DDR2 800

More about : system memory

a c 128 } Memory
December 1, 2010 1:10:59 PM

Artifacts on the screen indicate a wrong video driver or inadequate power supply for your video card. Also check the power supply connection to the video card (if required).
m
0
l
December 1, 2010 1:36:46 PM

o1die said:
Artifacts on the screen indicate a wrong video driver or inadequate power supply for your video card. Also check the power supply connection to the video card (if required).


Thanks for the reply. I've recently installed Catalyst 10.10, but I had the same problem with 10.8, so maybe not the driver? My PSU is a Coolermaster GX 650W, which I think should be adequate (although I know it's had mixed reviews). Other games I play that max out the GPU don't seem to have any of the same problems.

Would this explain the high RAM usage though? Especially the delay and HDD use when switching to another program.
m
0
l
a c 128 } Memory
December 1, 2010 1:51:17 PM

Maybe a simple software issue. I use ie privacy keeper to cleanup my drive everytime I exit explorer. Microsoft's security essentials is my virus software, and it works pretty well. Try cleaning up your drive first.
m
0
l
!