When i insert my graphics card my computer starts up but no display

Hello,
i have a geforce 7600 gs 8x apg everytime i put it in the computer boots up but screen stays blank weather the moniter is pluged into the motherboard onboard video or the video card, but the moniter works fine in the onboard video when the card is removed please help
8 answers Last reply
More about when insert graphics card computer starts display
  1. That is odd. The only advise I can give you is to go into the bios when the card isn't inserted and change the settings there.

    It might have a setting stating to use pci over on board or something like that. Change it to use the agp over pci or on board.

    I hope that helps.
  2. thanks ill try tommorrow and get back to u
  3. Did you have this card working previously or did you just get it? What kind of PSU and motherboard do you have?
  4. megamanx00 said:
    Did you have this card working previously or did you just get it? What kind of PSU and motherboard do you have?


    350w psu
    foxconn motherboard cant find model number
    the driver is out of a friends computer he upgraded and passed it on to me, so it was working
  5. when i said driver i meant graphics card

    thanks
  6. are you sure your mobo supports agp 8x? some are only 2x, or 4x.
  7. DiscoDuck said:
    are you sure your mobo supports agp 8x? some are only 2x, or 4x.

    the motherboard is also out of his computer he said they worked together
  8. begining to think my mates an idiot just put my ati 9200se in and the computer has fired up fine, installing the software now, think i will put the geforce away till i up grade

    thanks everybody
Ask a new question

Read More

Nvidia Graphics Cards Computer Video Graphics Displays