Sign in with
Sign up | Sign in
Your question
Closed

Asus Sabertooth x58 Mobo Boot Problem

Last response: in Motherboards
Share
December 5, 2010 4:23:51 AM

Hi,
i built a new system however i couldnt reach bios yet. My system is:
Intel i7 950
Asus Sabertooth x58 Mobo
4gb x 2 modules Corsair 1333 mhz Rams (Compatible with Mobo Checked)
1 Tb Seagate 7200 Sata Hdd
Lg Dvd Rw Sata
MSI Cyclone 1 gb gtx460 graphic card
Coolermaster Silent serie 850 Watt Power Supply (i think it is quiet enough)

After i turn on sabertooth mobo page comes and 4 options i can pick 2 of them 2 of them dont work. Del button for bios setup or tab for smthng. Then Black page comes which shows specs of pc when you start the pc like cpu i7 950 rams 8150 mb OK and us connecters ok etc.
However pc freezes here on this black page. There is a red light flashing on mobo Boot Device Led. Sometimes instead of this black page there is a screen like mixed black and whites like broken screen. Please help i tried many configs about connections and tried to start with just 1 ram module and many many diagnostics.Also tried to start without all cables except cpu hdd 1 dimm ram and cpu fan connection. However this led still flashing and still freezing at that page. Please help.

Best solution

a b Ĉ ASUS
a b V Motherboard
December 5, 2010 5:04:48 AM

You'll need to go through this checklist . . . not just saying "I did that", but using it as if you were checking someone else's work:

http://www.tomshardware.com/forum/261145-31-perform-ste...

This sounds like a power or graphics issue, but if you don't find it during the checklist we likely will be getting into parts swaps.
Share
December 6, 2010 12:48:47 AM

Thank you I just solved the problem. Changed mobo and it's running like a cheetah right now :) 
Score
0
Related resources
a b Ĉ ASUS
a b V Motherboard
December 6, 2010 12:53:47 AM

Grats! Glad you're up and running.
Score
0
December 6, 2010 6:27:04 AM

Best answer selected by codeihk.
Score
0
a b Ĉ ASUS
a c 135 V Motherboard
December 6, 2010 12:34:03 PM

This topic has been closed by Maziar
Score
0
!