Sign in with
Sign up | Sign in
Your question

My dvd-rom does not recognize some DVDs

Last response: in Storage
Share
May 2, 2012 7:12:52 PM

I have an ASUS K501 running Win7 and an HL- DT-ST-DVDRAM GT10N SCSI CDROM. This is the second of the same drive I have installed on this machine. Currently, it fails to recognize store bought DVDs from the US. I am deployed to Afghanistan, and it plays the locally available DVD Rip disks just fine. The last drive did the same thing after I was deployed to Iraq and played the movies bought there. Eventually, it failed to recognize almost every disk inserted and I was forced to replace it. This new drive was just installed six months back and was playing US DVDs for the first few months, but I had not tried them for the past few months. I recently attempted to play some local movies, but the quality of the recording was so poor, that I was forced to copy them to my hard drive for them to play properly. Since then, my drive fails to recognize conventional DVDs but will still recognize a blank DVD-R or a locally made DVD Rip on DVD-R. Has running these local DVDs done something to damage my system? Since this is the second occurance of exactly the same issue, I'm wondering if it is that or just crappy hardware. When I removed the drive, I noticed it had a non-typical connection, and was forced to replace with exactly the same model drive, as I could not find another brand with that same type of connection. Any insight would be appreciated. Thanks

More about : dvd rom recognize dvds

a b G Storage
May 2, 2012 9:07:53 PM

You're certain it's not a region based issue? Right click on "Computer" select "Manage" click on the device manager option there, then find your cd drive and right click and select "properties" then click the dvd region tab.

It doesn't directly explain the issues you're having, but if the region got changed too many times and it's stuck on somewhere outside of the US you won't be able to play US coded dvds.
m
0
l
May 3, 2012 8:50:08 AM

Yes, I've checked that already. It's always been set on region 1 and I never physically changed it.
m
0
l
May 16, 2012 1:30:32 AM

Well, the one reply I recieved wasn't what I needed, since that was the first thing I checked. Any other ideas?
m
0
l
!