When I hit power button, screen goes black PLS HELP

I am seriously at my limit spent 3 days I still cant figure it out, done probably 100 reboots.

Contacted ASUS Support they are useless still in contact with them in troubleshooting this matter.

This is my issue.

When I hit the Power Button my screen goes black, before a bios revision it would just reboot my computer.

YES I have set Power Options, Power Button to shut down computer.

I noticed I am missing a Sleep Button Action as its not in my menus. Maybe this could be a leading reason why this is happening? Anyone know how to get this option to show up?

I have used another computer cases front panel and same issue occurs so it cannot be my front panel.

I have a gut feeling the OS ACPI is completely being ignored when it comes to what the Power Button should do, if I set it to Sleep/Hibernate/Shut Down SAME thing still occurs.

I have got the Power Button to work successfully maybe 8 times out of the 100. It actually Logged off, Saved Settings and Turned of Computer as what I am trying to get it to do.

I have reinstalled the ACPI driver from ASUS but nothing changed. Have the lastest BIOS Revision as well. I have removed battery and cleared CMOS as well. Also loaded default BIOS settings.

My System:
HAF 922
Phenom II 955
G Skill Ripjaws DDR3 1600
750GB WD Black Cavier
1TB Green Cavier
320GB Cavier
Logitech Illuminated Keyboard (Maybe can use ACPI I think dont know if it can conflict?)

Weird thing, guy at ASUS told me to set it to "S1 Only" in BIOS and it actually worked twice, third time I hit the power button it went back to same behavior.

I noticed my chances are higher for it to turn off properly when the power options advanced settings window is open for some reason...

I hope someone knows how to fix this.

Thanks In Advance.
4 answers Last reply
More about when power button screen black help
  1. Perhaps try re-flashing your BIOS back to that old version that didn't have this problem? Did you flash it to the latest version for a particular reason?
  2. It never worked, first thing I did when I built the PC was update BIOS.

    Perhaps Ill try an earlier BIOS version.

    Any other ideas?
  3. If the earlier BIOS versions don't work, I'll take a shot in the dark and say your board may be defective? I'm not really sure what to make of this issue right now though... definitely got me scratching my head.
  4. same issue here. must be BIOS needs fixing... Have to soft shut down & just use button to turn on 'til Asus fixes it.
Ask a new question

Read More

Configuration Computers Power Windows 7