Sign in with
Sign up | Sign in
Your question

Help with 5770 drivers

Last response: in Graphics & Displays
Share
March 14, 2010 4:57:11 AM

OK guys i have a new computer i built with a 5770 sapphire. This is my first build everything seems to be going ok sept when im in wow my game freezes up some times for a few sec and my screen will flash once and im back playing. I used the disc that came with the card to install the drivers.

Can i uninstall the drivers and install the drivers from the AMD website? If i can i was looking and there is like 6 or 8 to pick from do and im a noob and dont know witch one to Download can someone plz help?

More about : 5770 drivers

a b \ Driver
a b Ý World of Warcraft
March 14, 2010 7:56:00 AM

Yes you can download directly from AMD's site,for your situation do a clean install,here is how:
1_Download and install driver sweeper from here: http://www.guru3d.com/category/driversweeper/
2_Go to add/remove programs and uninstall your current driver from there,restart after uninstalling and go to safe mode
3_in safe mode,open driver sweeper,check "ATI Display" and click clean,when its done,restart and boot normal to windows
4_Download and install the latest drivers from AMD's website and after the installation,restart and its done
March 14, 2010 1:05:35 PM

^+1
Do as Maz said... :) 
Related resources
March 14, 2010 3:39:37 PM

OK but witch Drivers from the site do i Down load there are a few of them and i dont have a clue to witch one or if i need more then one?
March 14, 2010 7:51:01 PM

How do i boot in safe mode cause the F8 dont work just brings up a window and asked do i was to boot from my sata HD or my cd/dvd
March 14, 2010 8:26:19 PM

OK i guess i got it all done and down loaded and installed. For now im running 1024/768 cause this is a really old monitor plan to get a nicer one soon. Now should i change any settings in the catalyst? Also how i know its working right?
a b \ Driver
a b Ý World of Warcraft
March 15, 2010 6:38:48 AM

No you should keep everything at auto for now.
At your first post you said you have some freezing problems with your card,so is it fixed now ?
March 16, 2010 4:14:43 AM

Maziar said:
No you should keep everything at auto for now.
At your first post you said you have some freezing problems with your card,so is it fixed now ?


No it still does it some times in world of warcraft idk how to test it or what to do.
a b \ Driver
a b Ý World of Warcraft
March 16, 2010 6:48:43 AM

How is the situation in other games ?
March 17, 2010 5:06:37 AM

Maziar said:
How is the situation in other games ?


Dont have any other games lol i have 1600 ram i heard amd runs best at 1333 should i slow my ram down?
a b \ Driver
a b Ý World of Warcraft
March 17, 2010 7:44:04 AM

No the RAM is fine,is there any way to test other games ? because its hard to judge with only 1 game
March 25, 2010 5:24:40 AM

Maziar said:
No the RAM is fine,is there any way to test other games ? because its hard to judge with only 1 game


Ok i found a call of duty 2 disc laying around so i tryed it out for about 30 min. i got 3 freeze ups the first was like the blue screen of death i just clicked the widows key to get out of the game so it was like just the game froze not the hole comp. The other 2 freeze ups where like 5 sec long screen would go blue then blink and was fine.

What should i do? :( 
March 25, 2010 6:23:43 AM

daman said:
OK i guess i got it all done and down loaded and installed. For now im running 1024/768 cause this is a really old monitor plan to get a nicer one soon. Now should i change any settings in the catalyst? Also how i know its working right?


If you are running at only 1024x768 then I very much doubt the GPU is your problem. Please list the rest of your system specs, including operating system.
March 25, 2010 7:18:19 AM

Herr_Koos said:
If you are running at only 1024x768 then I very much doubt the GPU is your problem. Please list the rest of your system specs, including operating system.


windows 7 64bit. amd 945 quad 2.8ghz. 5770 jumper saphire. 4g g skill ddr3 at 1600 650w antec psu
Anonymous
a b \ Driver
a b Ý World of Warcraft
March 25, 2010 11:30:33 PM

the GPU is the problem . . .

I also bought a pc with HD5770 and i get frezzings/crashes/bluescreens and so...

Some dude on this site, said that i should install catalyst 9.8, but when i do it the system doesn't recognize my GPU...

So im stuck with the newest drivers...
Anonymous
a b \ Driver
a b Ý World of Warcraft
March 25, 2010 11:33:34 PM

And with the freezes and crashes...
March 26, 2010 4:25:40 AM

Hmm so what are we to do to fix this?
a b \ Driver
a b Ý World of Warcraft
March 26, 2010 5:45:20 AM

Can you try this card in another system ?
March 26, 2010 6:04:58 AM

nope dont have another computer to try it in. i have been searching and loys and lots of ppl are haing these problems some ppl say to fix the voltage and stuff so it always runs high i have not tryed this yet.
a b \ Driver
a b Ý World of Warcraft
March 26, 2010 11:49:03 AM

Download GPU-Z and then run a game for about 5-10 mins,after that minimize the game(don't quit) and see if the clock is running @ the correct speed and its not down-clocked
March 26, 2010 2:54:50 PM

Maziar said:
Download GPU-Z and then run a game for about 5-10 mins,after that minimize the game(don't quit) and see if the clock is running @ the correct speed and its not down-clocked


ok i have that ill try it tonight and get back to ya.
March 26, 2010 3:29:57 PM

I must be the lucky one, no problems on this side with HD5770
!