Sign-in / Sign-up
Your question

Asus p5lp-le cannot working with hd 5570

Tags:
  • Motherboards
  • Asus
  • HD
Last response: in Motherboards
December 6, 2010 1:35:34 PM

Hi, my mate has motherboard asus Asus p5lp-le and his father him bought graphic card gigabyte radeon hd 5570. After plugging computer not working just black screen. My view is that not because motherboard support pci-express 2.1. I know that backward compatible on 2.0. But I don´t know if works at this motherboard pci-express 16* 2.0 or 1.1. Or this is something else. Thank´s for answers and sorry for my bad english, I can not a lots of good at english. Hi

More about : asus p5lp working 5570

December 6, 2010 3:30:11 PM

Hi there.
what brand is the power supply and how many watts is it rated for?
Does the power supply support the card properly?
What was the previous graphics card?
Did you select primary graphics adapter to PEG (PCI-E graphics)?
a c 436 V Motherboard
a b Ĉ ASUS
December 6, 2010 3:34:21 PM

According to the card specs, you need a minimum of a 400 watt power supply. Check your ps label. For a replacement brand, I recommend ocz, antec, corsair, enermax, or seasonic. All have good warranties and run well under load.
December 6, 2010 5:48:09 PM

Previous graphic card was nvidia geforce 7500 gt ( broken ) and previous power supply was delta electronic 268w.
Goes at integrated graphic card and all working ( with new power supply )
His specifications computer are:
Motherboard: Asus p5lp-le
Cpu intel pentium D 915 2,8ghz
Operation´s memory: ( brand I don´t know ) are 1* 1gb and 2* 512mb ddr 2, frequency I don´t know
graphic card: gigabyte radeon hd 5570 1gb ddr 5
Power supply: Evolve 400w ( Know that this brand is scrap but his father is mulish a says that is great brand lol xD )
I tried one graphic card ( MSI r5770 hawk of course functional ) and no working of course with better power supply ( fortron black power 550w )
It´s weird
Motherboard his with integrated graphic working but s dedicated graphic card not working.
He talking that is this slot on motherboard. I think it's nonsense because it not working full motherboard.
I think that computer would to can to cope had manage
Processor 95w, graphic card 43w, ram 25w, MB 20 w, disk ( 2x ) 20w, buffer 10w is altogether 213w indicative at 100 % load.
Sorry for my bad english !!!