Sign in with
Sign up | Sign in
Your question
Solved

Dumbfounded: BFBC2 charactor looks straight into sky. Vid card issue?

Last response: in Graphics & Displays
Share
March 14, 2010 11:32:05 PM

1 month old Build:

i5 750 Lynnfield
ASUS P7P55D Evo
Sapphire Radeon HD 5850
Gskill Ripjaws 1600 4GB
Logitech G500 gaming mouse



I'm not sure where to post this. Hope this is the right place. Here is my issue. I'm playing BF: Bad Company 2, and suddenly, after playing without issue for 2 weeks now, my ingame charactor starts looking (pointing the weapon) straight into the sky. I run around, and all I see is the gun pointing into outer space. If I run to a vehicle, or machine gun, and "Enter" it, I see normal, but the gun moves as far up (toward the sky) as it can, it what seems to be it's attempt to do what the infantry charactor does. Does this make sense at all? I'm dumbfounded. I've tried:

- Different server
- Rebooting
- Different mouse
- A full uninstall, and reinstall of the game

None of these changed the charactor from staring into the sky when I try to play. I just now loaded up the older Battlefield 2 game, and it plays fine. NO staring into the sky there. So clearly it's a BFBC2 problem. Does anyone think this could be a driver, or compatability issue? The game has played perfectly till just now. Since the older BF2 game works fine, and I totally reinstalled BFBC2, it has to be something with the game itself, and not some sort of setting. All the settings would have been defaulted upon the full reinstallation. This is truly bizarre. Any advice would help.
a b U Graphics card
March 14, 2010 11:39:53 PM

I had the same thing happen. There is a way to fix this
right click on the BFBC2Game.exe
go to compatibility
first try clicking on
disable desktop compostion OR
the one under that
disable display scaling on high dpi settings.
m
0
l
March 14, 2010 11:44:44 PM

I'll try that now.
m
0
l
March 14, 2010 11:48:10 PM

Um, ok, where do I actually find that file. In XP I could find everything. Not so with Windows 7.
m
0
l
a b U Graphics card
March 14, 2010 11:52:52 PM

c:\Program Files (x86)\Electronic Arts\Battlefield Bad Company 2

Your scaring me :) , replace C, with drive where you installed game.
That the exe, you click on. Your desktop shortcut should lead to BFBC2Game.exe
m
0
l
March 14, 2010 11:58:29 PM

Ah, ok. disabled the dpi option, loading up the game now. Let's see what happens.
m
0
l
March 15, 2010 12:02:33 AM

Strike one on the dpi option. Trying the desktop composition box now.
m
0
l
March 15, 2010 12:05:33 AM

Nope, that didn't work either. Any other ideas? This is so messed up. One minute fine, the next, staring into the sky. I have no idea how this could happen, and how a complete reinstall of the game couldn't fix it. What do I do now?
m
0
l

Best solution

March 15, 2010 3:24:25 PM

Just unhook your joystick from your CPU. If that doesn't work then reset your in game controls back to default under options in the game. Do not setup any joystick controls at all. There seems to be an issue between the joystick and the keyboard commands. Try that!
Share
March 18, 2010 1:56:33 PM

It was the joystick. A friend of mine had the same issue, and he told me what docj said, to disconnect the joystick. I, like most people with this problem, had been using a Logitech 3D Extreme. Apparently there is a compatibility problem with BFBC2, and certain sticks. Thank you everyone for your help.
m
0
l
March 18, 2010 1:56:51 PM

Best answer selected by real world.
m
0
l
Anonymous
a b U Graphics card
May 18, 2010 8:31:39 AM

hey oaks.

i seem to be having the same problem with the mouse checking the sky out. Also running win7 and have ATI Radeon 4890. keyboard wont use strafe left/back only left and forward and mouse is in the sky. lol havent even played yet. Ive tried the sompatability issue and the dpi check box...using a microsft arc no joystick and this is baffleing my brain....anyone heard of anything like this please let me know..

.THX Cedric
m
0
l
May 18, 2010 1:49:12 PM

I would make sure you have all the latest drivers for your mouse, etc.

If that don't work then reset all of your in game setting to default and see if that corrects the issue. If it does correct your issue then slowly and painstakingly start changing your controls in game to what you want them to be. BC2 is a very very touchy game.
m
0
l
February 15, 2013 1:07:09 AM

just scroll down all the the joystick settings to 0% and wallah
m
0
l
!