Sign in with
Sign up | Sign in
Your question
Solved

USB 3.0 and external hard drive problem - constant autoplay pop up message

Tags:
  • Hard Drives
  • External Hard Drive
  • USB
  • USB3
  • Storage
Last response: in Storage
Share
May 4, 2012 4:42:23 PM

Hello,

I have a Buffalo Ministation USB 3.0 external hard drive connected to my AsRock 770 Extreme 3 motherboard (Win 7). The Windows autoplay banner keeps on popping up at random intervals. It seems as though Windows loses the hard drive and immediately finds it again.

What I've tried:
- changing cable (bought a new 3.0 cable)
- changed the electric lengthner
- tried the drive in an USB 2.0 port - no problems, no autoplay popups
- tried another Buffalo (USB 2.0) drive in the 3.0 port - no autoplay popups, works normally
- tried removing some of the more power hungry USB devices I've got to see if this is a power related problem - no effect
- disabled the option in Device Manager that allows Windows to put USB devices in power saving mode

I've got the latest USB driver installed. The problem seems to appear only when using my drive with the USB 3.0 cable and port.

I'm running out of ideas here - any suggestions, please?

More about : usb external hard drive problem constant autoplay pop message

August 1, 2012 4:07:47 AM

I have this exact same problem on my ASRock Extreme3 Gen3 and my Biostar A870U3. It's driving me crazy. I'm using a Syba CL-ENC50038 hard drive dock enclosure with a very short cable. When I use the USB 3.0 extension cable it shuts off and on so frequently that I can't copy anything. Both boards use the ASMedia 1042 3.0 controller. Have been to Station-Master to get latest ASMedia drivers but this hasn't helped either. The dock uses a FNet Jmicron interface via software install. The ASRock natively comes with XFastUSB which appears nearly identical. Replacing the short m-f cable with longer m-f cables that can reach the back of these machines might be a solution but I would rather solve the problem. Tom's recently had an article on how these ASMedia controllers work on USB 3 but it didn't quite address this problem. Like you, I'm searching for an answer and hoping that this won't be a lost cause...
m
0
l

Best solution

June 9, 2013 12:02:48 PM

Hi guys, I had the exact same problem. I even posted a similar question here. But did not get any solution. I downloaded and installed this file http://downloadmirror.intel.com/19880/eng/USB3.0_allOS_.... Its a USB 3 driver. As you can see you will find it in the intel's webpage. Install it and then run the program. Check the "Disable USB 3.0 power management function" then hit ok. It is still working for me so hope will do the same for you!
Share
Related resources
!