Sign in with
Sign up | Sign in
Your question

Windows only recognizing half of RAM - tried everything

Last response: in Motherboards
Share
December 7, 2010 11:43:17 PM

I recently purchased a H55M-E33 msi motherboard model # 7636, 4 gigs of Corsair Xms3 DDR3 memory in 2 sticks, and an intel i5 processor. I plug the sticks in and boot up the computer, only to find that i have 4 gigs of RAM (1.96) usable according to my system properties. Thing is, everywhere else I check it says I have 4 gigs of physical memory installed. I've tried everything to get windows (Windows 7 64 bit) to recognize my 4 gigs:

played with the placings of the RAM sticks (If I have one at a time in, BOTH of them result in windows telling me I have 2 full gigs with one in, and then switched with the other which leads me to believe its not the RAMs fault)

I've flashed the BIOS to the latest version, 1.9 with the USB flash loader tool thing. (I've done it properly, all the way to the point where it says update successful and I restart the computer. I know it updated because when I enter the BIOS the version is updated to 1.9)

Looked underneath the processor at the pins, none of which are out of place or missing.

Refreshed my "windows experience index"

Ran Memtest86 multiple times with 0 errors.

The BIOS itself tells me I have > 4000 bytes of physical RAM memory

Resetting BIOS to defaults after a "bad Cmos" error from a flash

I have run msconfig and made sure the max memory setting is not checked

I've tried everything I, and apparently every thread I've looked at, seem to know. I'm wondering if a fresh reinstall of my windows 7 will fix anything. Any thoughts?
a c 435 V Motherboard
December 8, 2010 12:46:23 AM

Forget windows. Windows doesn't do a refresh of it's readings whenever you add ram or anything else. If your bios and cpuz detect the correct amount of ram, then you're fine. I have the same board. Set your cpu fsb at 160 for 1600 ram if it's not running at full speed. Set the max fsb and ram configurator setting (I forget what it's called), reboot, and wait about 30-45 seconds for 4-6 reboots while it detects the correct fsb for your cpu and ram; you'll get a blank screen. Then when the post screen appears, disable the max fsb setting and enable "spread spectrum" (I turned this setting off while setting the overclock setting). Once the max fsb has been locked, you won't be able to increase it any higher, but it's a safe and stable way to overclock. The cpu fsb setting becomes "grayed out" after you set it. The "max fsb" is in the upper right section of the bios (don't remember the name of it).
!