Sign in with
Sign up | Sign in
Your question

Windows 7 32bit only detected 2gb rams while i have 3.

Last response: in Memory
Share
December 8, 2010 4:33:13 PM

Hi there,
I just bought a new pc few days ago and i was using it happily for a day or so until i sudden go to check for the properties of my computer and saw that it stated i only hav 2.0gb of rams, which i'm sure i have the Corsair TR3X3G1333C9 XMS 3x1GB rams installed.
I'm using windows 7 32-bit, which i know it only detect maximum up to 4gb of rams, but i only got 3, and it should be detectable.
While the CPU-Z detected correctly for 3, but the windows don't. And i have no idea what had gone wrong, whether is it my asus P6T SE mobo or what?
Please help me. THanks in advance.

Available
Cached
Total
Installed


a c 347 } Memory
a b $ Windows 7
December 8, 2010 5:38:20 PM

Welcome to Tom's Forums! :) 

The TR3X3G1333C9 is listed for your MOBO - http://www.corsair.com/configurator/product_results.asp...
1333 9-9-9-24-2T @ 1.5v

Before digging into the BIOS, please post the following image or at minimum the numbers:
Hardware Reserved
--
Available
Cached
Total
Installed


Verify the following are set a below:
December 10, 2010 3:56:16 AM

Anybody can help? I've read other posts, they said using memory remap, but bios doesn't have this feature. So how am I gonna fix it? update the bios or what?
Please help me, I'm kinda noob in this. Any reply is much appreciated.
Related resources
a c 347 } Memory
a b $ Windows 7
December 10, 2010 2:31:53 PM

It is NOT a 'Mapping' or 'Update' issues at all. Thankfully, you posted what I asked for - in short the 'RAM' isn't being 'seen correctly' in the BIOS.

Therefore, the probable causes: Incorrect DIMM slots, Bad DIMM slot, Under powered, Bad stick are the likely subjects.

Incorrect DIMM slots
RAM needs to be installed in the RED slots only.

Bad DIMM slot
Use Isopropyl alcohol to clean the DIMM slots - clean the RAM contacts, leave damp insert in DIMM slot, wipe-off, and repeat (2) times per DIMM slot. During production machine oils are used to form/shape metals {DIMM Slot} and often aren't properly cleaned.

Under Powered
As I posted before, enter the Speed and Timings manually into the BIOS -> 1333 9-9-9-24-2T.
See pages 3-12~3-16. Also, increase the QPI/DRAM Voltage 1.1~1.25v. Normally, this is not needed with 1.5v RAM or in a 3-stick install.

Bad Stick
Create a bootable CD/DVD of Memtest86 {ISO/Zip} and run (2) passes - http://www.memtest.org/

Report back your findings, and Good Luck!
December 12, 2010 10:58:06 AM

I've tried to change the speed, timings and the voltage in the BIOS as recommended by jaquith, but no hope. Then I tried to swap it one by one, and found that one of the stick is defective as the slots are working fine with the other 2 sticks.
So I sent that defective stick for RMA, and just received a new 1 from the shop this morning and went back home inserted it into the slot, power on, finally, the system detected all 3gb. Finally problem solved!

Btw, thanks for all of you who take time to reply on my post. Really appreciate it. THanks a lot!
December 12, 2010 7:44:31 PM

I thought the 3x1GB are triple channel, so why it's not triple but single?
I know little about these, so please enlighten me.
December 12, 2010 8:05:22 PM

Yeah, my mobo is asus P6T SE, so it has x58 Chipset with i7core which support triple channel.
December 12, 2010 8:44:44 PM

A Sapphire Radeon HD 5670.
a c 347 } Memory
a b $ Windows 7
December 12, 2010 8:55:53 PM

wahzi said:
I thought the 3x1GB are triple channel, so why it's not triple but single?
I know little about these, so please enlighten me.

Duh?!! Yeah... 3 sticks = Triple Channel; size has nothing do do with it; assuming supported sizes and correct slots are being used. If you want 3GB that's okay with me.

Example:
a c 347 } Memory
a b $ Windows 7
December 12, 2010 8:58:11 PM

Quote:
1GB or 512mb.?

Yeah, ANY dedicated GPU is going to use some VARYING amount of 'Shared' NOT 'Dedicated' RAM.
December 13, 2010 4:34:47 AM

Quote:
1GB or 512mb.?


It's 1GB dedicated memory version. Sorry for not stating clear.
December 13, 2010 12:19:50 PM

Yep.
a c 347 } Memory
a b $ Windows 7
December 13, 2010 2:10:37 PM

The Differences are Shared system memory vs Dedicated system memory -> IF it is the Dedicated system memory then there's where your missing RAM went; however if it;s Shared system memory then the RAM is still 'missing'.

Example {My wife's rig} note the differences in memory:
December 13, 2010 2:56:37 PM

I only get a 5.9 WEI with my 1TB WD Caviar Green SATA. sign
a c 347 } Memory
a b $ Windows 7
December 13, 2010 3:40:07 PM

My wife's rig is a 128 GB Kingston SATA2 Gaming MLC SSD. The C300 and newer SSDs run faster. The second HDD is RAID 1 Hitachi 1TB/7200/32MB {Intel RAID}. She also has 1600 CAS 9 3X2GB Dominator; vs the CAS 8 on the rest.

Here's the 'old' HDD data from the UD3R; I haven't looked since I moved them to the ASUS P6X58D-E:
!