Need some BIOS help

This is my first build. I have a MSI 770-G45 with AMD Phenom II X2 555 BE running 2x2gb G.Skill ram and Sapphire ATI 5770 graphics card. My problem is after I reset the CMOS I can enter the BIOS, no problem. But after I save and the system reboots I can no longer enter the bios. I get the MB brand screen and it goes black after that. Do I need to change some BIOS setting? Should I enter RAM timings manually? Should I update the BIOS with the USB? Is this normal? I need some help, I am banging my head against the wall right now, trying to figure this out.
6 answers Last reply
More about need bios help
  1. In BIOS, be sure the hard drive with the OS installed is set as a 'boot device'. Set is as the first boot device for faster loading times. Of course set the RAM speed, timing and voltage the RAM maker's specifications.
  2. i don't have an OS installed yet, would that be the issue? I can access the BIOS but like I said I have to reset CMOS constantly. But I will definitely set the RAM specs
  3. i was just checking my work and hoping i put it all together correctly
  4. So with no OS and the hard drive powered on and the SATA cable connected, the splash screen would show up when the system is powered on. Unplug the hard drive and BIOS wll appear when booted until the OS is installed.
  5. okay thanks. I will try that.
  6. Try to do a CTRL-ALT-DEL when it is at the blank screen and then select the setup entry key, like F2 or DEL to enter the BIOS after the restart.
Ask a new question

Read More

Chipsets BIOS RAM Motherboards