Sign in with
Sign up | Sign in
Your question
Solved

RAID10 Data Drive setup with SSD Boot Drive

Last response: in Storage
Share
May 6, 2012 10:29:15 PM

I have hit a snag while in the middle of a new build. I installed Windows 7 64-bit on a new 120 GB SSD attached to the 6 Gbps Intel SATA Controller of my new ASUS P8Z77-V Deluxe motherboard. The optical drive (Pioneer Blu-Ray Burner) is connected to the other SATA port on the same controller. I installed all of the Drivers from the Motherboard DVD. The install went perfectly and the system screams. The problems arise when attempt to setup the data drive/RAID array.

I then added four brand new 1 TB WD Caviar Black HDDs to the 3 Gbps Intel SATA Controller in the hopes of configuring them as RAID10 for use as a data drive for video editing. I went into BIOS (version 0703) and changed the SATA Configuration from AHCI to RAID. Then I went into the Intel Rapid Storage Technology Option ROM utility <Ctrl> +<I> and created the RAID volume with only the 4 HDDs (RAID10 with 64k stripe size). The RAID utility tells me the volume is okay and bootable. When I exit the RAID utility, I see the "Starting Windows" splash screen, but then instead of booting into Windows, I get the Windows Error Recovery menu with two options: 1) Launch Startup Repair and 2) Start Windows Normally. If I choose to Start Windows Normally, it just loops back through POST, and I end up back at the Windows Error Recovery menu again. If I opt to Launch Startup Repair, that utility eventually tells me that "Startup Repair cannot repair this computer automatically". The details of the Startup Repair claims "no root cause".

After briefly going insane (i.e., repeating same steps expecting different results), I eventually went back into BIOS and changed the SATA Configuration from RAID back to AHCI. When I do this, Windows starts up normally. If I go into the Windows Disk Management utility I can see all four HDDs. Very frustrated.

Anybody experience similar issues or have any ideas to force this configuration? Thanks!

CPU: i7 3770k
Motherboard: ASUS P8Z77-V Deluxe
Memory: 32 GB (4 x 8 GB) G. Skills Ripjaws X-Series DDR3 1600
Optical Drive: Pioneer BDR-2206
Boot Drive: OCZ Vertex 120 GB SSD
Data Drive: four 1 TB WD Caviar Black HDDs (hopefully someday in RAID10)
OS: Windows 7 64-bit
Power Supply: Corsair AX1200
a c 277 G Storage
May 8, 2012 1:04:24 PM

Unlikely, but is it possible that it is trying to boot from the RAID array instead of from the SSD?
Related resources

Best solution

May 11, 2012 3:33:14 AM
Share

The MS fix will not fix this problem. If you want to use any raid on the motherboard, you will need to set your bios to raid BEFORE installing Win7 on your SSD. When you do that, Win7 will install the proper raid drivers and you will be good to go even if you do not use the raid function. Keep in mind that once you install Win7 while the bios is in raid, you cannot just change your bios to ACHI or anything else.

How do I know this? Because I beat my head against the wall just as you are probably doing. I too tried the MS fix, but it did not work. Once I re-installed Win7 after setting bios to raid mode, everything worked just fine.
a c 277 G Storage
May 11, 2012 12:38:14 PM

williamPR - an excellent point. Do you think that a Repair Installation would put the correct drivers in place?

By the way, the only system on which I have ever seen an AHCI-installed OS not boot when the controller is set to RAID mode is a Dell. Maybe I've been lucky.
May 18, 2012 2:48:59 AM

Best answer selected by vtberger.
May 18, 2012 2:58:08 AM

Thanks williamPR. I tried several different suggested MS "fixes" to no avail. The only thing that ended up working was reinstalling Windows 7 on my SSD AFTER configuring the SATA Configuration in BIOS to RAID mode and setting up the Data Drive in RAID 10. This was frustrating to discover because several articles on the topic (i.e., setting up RAID 10 data drive with SSD boot drive) suggested installing Windows 7 on the SSD first without having any of the RAID disk members connected to avoid having Windows put some system files on the RAID array. Oh well. My new build is up & running per my design and screams. Thanks for everyone's time on this!
May 18, 2012 3:14:28 AM

I think maybe some points got missed, maybe by me.

If I understand correctly, vtberger already had his OS on the SSD, and wishes to set up his RAID array for another use.

In which case the hardware fix is to simply set up the discs for RAID by enabling them for it in the BIOS. Then on boot up, hit whichever 'F' key your BIOS has for the function to "Set up RAID array". Set up your array, then reboot from the SSD and the OS will then install all the drivers for the array on boot up.

Or did I miss something?
!