Sign in with
Sign up | Sign in
Your question
Closed

P2370HD monitor connection to PC via HDMI cable

Last response: in Graphics & Displays
Share
March 16, 2010 2:44:36 PM

Hello!
Recently have bought Samsung P2370HD and there is problem with connection to PC via HDMI-HDMI. It don't support 1920x1080 resolution- smeared image, but with 1680x1050 works clearly. It also works good via VGA cable with 1920x1080 resolution. Video card is integrated Intel Graphics Media accelerator HD (H55M-USB3). If you can give some issue, please emailed me on
In advance thank's!
a b U Graphics card
March 16, 2010 11:28:46 PM

Hey vanecdm,

The Tom's forums are designed to both answer specific questions and provide reference for those searching online--so answers are not emailed to individual persons.

In order to get better performance at high resolutions you should get a discrete graphics card instead using your computer's integrated graphics. Integrated graphics are the cheapest, bare minimum graphic performance you can get in a PC--even a $20 graphic card would perform much better.

If you just want normal PC performance I would suggest you consider an ATI Radeon 4350. If you want to play games, etc you would want to pay more for a good card.
a b U Graphics card
March 16, 2010 11:33:27 PM

Have you installed the newest graphics driver as well as the monitor driver?
Related resources
Anonymous
a b U Graphics card
July 7, 2010 10:08:24 AM

My VAIO laptop (with ATI Mobility HD4650 graphics) has exactly the same problem that vancdm had with the Samsung P2370HD, but no problem with the Sony 40" XBR HDTV. I think there is definitely a compatibility problem with this Samsung.
a b U Graphics card
July 7, 2010 4:26:05 PM

Do you have another cable, perhaps the quality of the cable is the problem.

Try a DVI cable.
September 16, 2010 11:40:07 AM

Hi all,

I also now a proud owner of the same model Samsung Syncmaster P2370HD and I finally figured how to get around this blurry text problem:

Under Menu is the suboption Input with 2 other subordinate options. Navigate to Edit Name and choose the HDMI option.there you can state what device you are using,and the resolution problem would be settled as soon as you choose PC. and there you have your native resolution. hope i could help :)  Have fun!

Greets
Edem C
November 7, 2010 2:39:28 PM

Edem C your advise helped me a lot to adjust my pc to monitor connection by HDMI on my P2370HD
Thanks a lot.
a c 271 U Graphics card
November 7, 2010 2:45:50 PM

This topic has been closed by Mousemonkey
!