Sign in with
Sign up | Sign in
Your question

Half speed writes on new mushkin deluxe chronos

Last response: in Storage
Share
May 7, 2012 11:40:42 PM

So i just got a new 240gb Chronos deluxe, http://www.mushkin.com/Digital-Storage/SSDs/MKNSSDCR240...


And here is my result from crystaldiskmark3.

Sequential Read : 489.417 MB/s
Sequential Write : 186.132 MB/s
Random Read 512KB : 421.801 MB/s
Random Write 512KB : 186.809 MB/s
Random Read 4KB (QD=1) : 24.494 MB/s [ 5980.1 IOPS]
Random Write 4KB (QD=1) : 65.427 MB/s [ 15973.4 IOPS]
Random Read 4KB (QD=32) : 104.420 MB/s [ 25493.2 IOPS]
Random Write 4KB (QD=32) : 181.882 MB/s [ 44404.7 IOPS]

The read speed is great, but the write speed is about half what i should get, from what i can tell, where am i going wrong?

The drive is plugged in sata3_0, with nothing in sata3_1
ahci enabled, trim enabled(both double checked by tom's guides, http://www.tomshardware.com/reviews/ssd-performance-twe...)
Power link management is off
Firmware is latest version 502


My pc:
ASRock extreeme3 gen3 z68
i5 2500k @4.2
8gig g.skill
evga gtx580
Windows 7 pro x64

If its a bottleneck in my motherboard that i didnt know about, im fine with that, i just want to ensure this drive is 100% good before i make it my boot drive.

May 8, 2012 1:23:09 AM

UPDATE:

I ran ATTO benchmark and the results look normal, this is not my picture but my speeds are almost identical to this(its the same drive)
http://i1210.photobucket.com/albums/cc413/fowwiee/atto1...

I also tried a real world test and created a ramdisk partition, then copied a few gig movie back and forth, and both speeds were in the 500's, so i guess i am assuming that crystaldiskmark has a problem with this drive, or something else fishy is going on, either way i feel safe that the drive is in good working order.

If anyone with some real knowledge (instead of my learn on the fly stuff lol) has a comment, i would appreciate your input very much.

UPDATE #2:

This forum thread seems to explain my results very well, fully satisfied, now to get on with the windows install!

http://forum.overclock3d.net/index.php?/topic/43644-mus...
m
0
l
!