Sign in with
Sign up | Sign in
Your question
Closed

ATI Shapphire HD 4870 running hot?

Last response: in Graphics & Displays
Share
March 17, 2010 4:49:52 AM

Hey guys, this is my first time building a pc and after doing some research i am unsure about the temp of the gpu. it is a steady 77C and peaked at 78C after about 2 hours of half life 2 & Couter strike source. Those arent demanding games. It is a steady 77C while surfing the web and just doing regular things.

Specs:
MOBO : Asus P5Q3
Inteol Core 2 QUAD Q9550
4GB of Ram

Thanks for the tips and help in advance
March 17, 2010 5:14:47 AM

Try open your side case and see if that helps cooling down your temps...
Score
0
March 17, 2010 7:16:25 AM

^That definitely helps.

Try increasing your GPU fan speed too...
Score
0
Related resources
March 17, 2010 9:42:09 AM

ok tell us do u have a single slot card or double ..... if you have a single slot card then its runs hotter even if you are not playing games... means just browsing.
i have a XFX HD 4870 single slot and its idle at about 68c or sometimes 70C and its crashes in games ..then i RMA the card and got the new one and it also running hotter and idle at same 65C or 70 and i open the side case and its still hotter .Then i do a trick i just unplug the fan pin of the card (and lock the fan with the help of a pin to stop its rotation to protect fan brushes as the rotor RPM is 4000 and stock FAN has 2000RPM max. )and then add a rotor fan under it having RPM of 4000 and the card runs well and idle at 50C and fully loaded(during play of call of duty modern warfare 2) then 75C max. I 'll upload the video or picture for better understanding of how to cool ATI HD 4870 without stock FAN...if you want me to put a pic or video so do tell me if want a proper guide.

And also kindly upload the card pic or tell us about the exact MODEL NO
or post the link to the exact model page ,so we can see the card .

dont forget to mark as answer....!
Score
0
March 17, 2010 6:05:12 PM
Score
0
March 17, 2010 8:13:57 PM

okay well i have used this guide to run bios on the gpu to change the speed of the fan and it lowered my temps to 50C (http://forums.amd.com/forum/messageview.cfm?catid=11&th...) . but i went to turn off my desktop now i turn it on and everything runs but i have nothing going to my monitor. i dont under stand what happened i followed the directions to the t. Everyhting is lighting up, the video card is running but no picture is going to my monitor. any clue what happened?!
Score
0
March 17, 2010 8:25:57 PM

there is a possibility that the rewrite of the bios may have inadvertently killed your card. to test this, you should try and enter the motherboard bios. if you still get nothing, then i would rule the card dead
Score
0
March 17, 2010 8:52:03 PM

how would i check anything if nothings is being fed to my monitor? is there no going back to save the card?? f*** man...

Edit: also if i were just to get a new card wouldnt installation kill that new card also? i am so confused rite now it sucks
Score
0
March 18, 2010 4:01:15 AM

no, the bios on the card is on the card itself. if you were to get a new card, then maybe you could get into your old cards bios and set it back, or download a good set of bios and replace the ones you put in.

cant say if that will work or not. its just an idea
Score
0
March 18, 2010 4:45:33 AM

yup you can add more fans to get the card cool. I add two 140mm fan having 3700RPM cool the card and its idle at 59C and fully loaded at 75C max. and without extra FAN its idle at 70C and loaded at 86C.

By the way you get the bios from the web i'll post the link. But make sure it must be the new one not the old one.
if XFX HD 4870 bios will work on saphire then m gonna send you the Bios as i have a new one.

Score
0
March 18, 2010 7:25:54 PM

that would be awesome if you can post the link for the bios i still cant get it up and running though.. do you know how to unbrick it maggen?
Score
0
March 19, 2010 4:19:14 AM

yup give me ur email address i'll mail you the bios and after that u have to make a bootable flash drive and download ATI tool for FLASHing bios of the card.....waitin for ur email address....and i'll mail you the step by step instructions and tell u the whole procedure...
Score
0
April 22, 2011 1:45:26 PM

This topic has been closed by Mousemonkey
Score
0
!