Rear surround sound speakers not playing

I have logitech G51 5.1 speakers and a IDT 92HD73C1 Audio card. I do not get sound from my rear speakers when I plug in all ports for speakers, but when i plug in the jack for the rear speakers into another spot they work so i know it isn't the speakers. My card is a 6-channel so i don't know why it has a problem using the mic port for speakers. even when i plug the jack into the mic port it gives me an option to use it as rear speakers or a mic, but after selecting rear speakers no sound is played. Any help would be very much appreciated.
4 answers Last reply
More about rear surround sound speakers playing
  1. also i have enabled 5.1 surround sound but when i do the speaker test no sound comes from the rear speakers. all the others work fine.
  2. Have you tried watching a movie that is in surround sound. The rear and center speaker will not have sound if you are listening to a 2 channel audio source. Now some soundcards and onboard sound chips have the ability to output sound to all speakers from a 2 channel source usually called speaker fill.
  3. They should still play when i do the speaker test though i can't understand it.
  4. ajrskyline said:
    They should still play when i do the speaker test though i can't understand it.

    ajr, did you ever find out the answer? i am having the exact same problem, all work, except rear, and same thing, i tested the rear speakers on a different output, and they work fine. -Sean
Ask a new question

Read More

Sound Cards Speakers Audio Logitech Components