Sign in with
Sign up | Sign in
Your question

Asus sabertooth x58 freezing after sleep or hibernation

Last response: in Motherboards
Share
December 12, 2010 6:07:50 AM

Hi here's a weird one, X58 sabertooth and 2/Msi 460 Hawks running in SLI. Latest drivers and Bios. System works flawlessly. Except if I leave it logged on for any lenght of time it freezes coming out of sleep or Hibernation. I have adjusted the power properties to never shut off the Hard drive, but it still locks up unless I remember to log off. The screen will bring up my desktop but none of the icons will react, yet I can move my mouse cursor around. Then I have to cold boot to get it back to normal. I am running Win7 Ultimate. The system is stock, no overclock.

Any Ideas???
a b V Motherboard
December 12, 2010 11:16:23 AM

Is AHCI enabled in your motherboard? Maybe that will help with sleep/hibernation issues.
m
0
l
December 13, 2010 3:49:08 PM

gracefully said:
Is AHCI enabled in your motherboard? Maybe that will help with sleep/hibernation issues.


Thanks for your reply, No I didn't enable AHCI, unfortunatley I wouls have to reinstall the OS to test it.
Which I will do once I have some free time. I think you may be on the right track with this.

Thank you.
m
0
l
Related resources
December 13, 2010 7:23:46 PM

karlmotz said:
Thanks for your reply, No I didn't enable AHCI, unfortunatley I wouls have to reinstall the OS to test it.
Which I will do once I have some free time. I think you may be on the right track with this.

Thank you.


In my experience with windows 7, enabling AHCI after having installed with AHCI off, does not cause problems at all. When I did it, windows booted flawlessly, simply "recognized" the "new hardware" and took care of everything. from that pooint forward, I had the option of "safely removing" each of my available hard drives.

So, if you're planning on having to re-install anyway... i'd suggest turning it on and seeing what happens for curiosity sake :) 
m
0
l
a c 717 V Motherboard
December 13, 2010 7:53:38 PM

No, changing from IDE <=> AHCI often creates a corruption. The 'fix' http://support.microsoft.com/kb/922976 I doubt it's the problem.

To determine the cause:
1. Disconnect all USB devices {if you have an old PS/2 keyboard use it}
2. Run MSCONFIG, select diagnostic
3. **Open the Event Manager and review Critical errors {see below}.
4. Possible HDD errors - right-click [C] drive / Properties / Tools / Check now and select both options / schedule / restart takes a while... Worst case #4 is a good housekeeping task.

Corrects problem:
Then you have a USB or other software conflict. Add one device at a time. Otherwise, the following:
1. Load Diagnostic
2. Load Diagnostic + Microsoft
3. Load Diagnostic + Microsoft + Known {Apple, etc - SERVICES}
4. Load Diagnostic + Microsoft + Known {Apple, etc - SERVICES} + Startup {KNOWN}
5. Then start adding the rest 2-3 at a time; it is a slow process

Failure:
If this fails then you have a 'bad' or corrupted driver or a device that isn't ACPI {S1~S3/S4} compliant. Generally an old device. Use PassMark Sleeper to test http://www.passmark.com/products/sleeper.htm

Sleep hibernation {FYI/useful info} http://windows.microsoft.com/en-us/windows7/Sleep-and-h...

m
0
l
a b V Motherboard
December 14, 2010 6:56:00 AM

Here's a guide to enabling AHCI after installation. Do this before changing the mode.

http://forums.guru3d.com/showthread.php?t=313676

If you change modes before doing that, you will get a BSoD because Windows won't be able to find your boot HDD. It needs the AHCI drivers for that.
m
0
l
!