Sign in with
Sign up | Sign in
Your question
Solved

External HDD Not Showing Up

Last response: in Storage
Share
May 10, 2012 4:56:58 AM

I borrowed a friends external HDD to transfer over the bulk of our files, earlier today, to get our computer ready for reformatting. It was just time for a spring clean. Anyways, due how hot it was here, I decided to stop where I was and turn the HDD off. I tried disconnect the drive, but it wouldn't stop it. I gave up and pulled the plug on it.

Later tonight we tried watching a movie off this same drive. We plugged it into our friends laptop, waited for it to appear in 'my computer' and opened it up. We found the movie we were after, it displayed the image and the vlc logo etc. We double-clicked it, it opened vlc but nothing showed. We gave it some time, but still nothing. The loading bar at the top of the screen was moving very slowly...so we still waited. No matter what we did, we could not get any file to open. Again we couldn't eject the HDD, so we restarted the computer this time. When trying to open it up this second time, it said there was a problem and gave us the option of proceeding without scanning or scanning and trying to fix the issue. My friend went with this second option. It got stuck half way through, and we eventually had to give up. We unplugged the HDD and tried inserting it again. This time it wouldn't show in 'my computer'. We tried it on our computer...same problem, it wouldn't show. We tried looking in 'device manager' in case it had no drive letter. It wasn't there, and we couldn't find any trace of it.

We moved it back to the laptop where this time the drive shows in 'my computer'. However, it does not appear as a normal HDD does (with a bar at the bottom showing how much space has been used etc). It simply says 'local disk (F:) '. We can't open it either. We tried uninstalling it, with the hopes that when reconnected it would be accessible again. It didn't reinstall the drivers, and now nothing shows again.

It's a Western Digital Elements Desktop 2TB drive. Any ideas? We (stupidly) put a LOT of important data on there.

More about : external hdd showing

May 10, 2012 6:52:34 AM

Try to scan the drive for bad sectors. And next time, do not plug out the drive without using "safely remove" function, and it you cannot, just turn off your PC while the HAD is plugged in, then you can safely plug it out.

Try reading this guide, it may help: http://www.tomshardware.com/forum/265764-32-guide-insta...
m
0
l
May 11, 2012 5:45:56 AM

Well, we can't scan the drive for bad sectors because we can't find the HDD at all. As I described above (in my novel, sorry), no matter what we try, we can't get anything to show. Also, that guide says it's for internal drives only.

We're starting to wonder whether the usb controller has died. Although it would void the warranty, I'm wondering whether we might have luck by installing it as an internal drive.
Any thoughts?
m
0
l
Related resources

Best solution

a c 314 G Storage
May 11, 2012 1:05:27 PM

Removing it from the case and installing it internally is a widely-used second step in diagnosing the problem. First step is to try different cables and a different computer, to eliminate some variables. I think you did try another machine.

If it still ain't there, try recovery tools like Recuva, EASEUS Partition Recover, EASEUS Data Recovery, or any of the dozen free utilities you will see mentioned in these forums. Good luck.
Share
May 13, 2012 5:48:27 AM

I don't have any experience with this sort of software...but will certainly give it a shot! Thank you for the advice :)  Will try to work that out tomorrow.
m
0
l
May 23, 2012 6:24:54 PM

Best answer selected by youlo193.
m
0
l
May 23, 2012 6:26:40 PM

We had no luck with any suggestions. I checked the warranty, as soon as WD's RMA system was back online, and it turned out that it has been out of warranty for about a month. We are going to open it up, and hope it was just the enclosure. Thanks for all of your help everyone!
m
0
l
!