Sign in with
Sign up | Sign in
Your question

Help: ThinkPad T20 cpu fan problem

Last response: in Laptops & Notebooks
Share
September 13, 2004 2:43:56 AM

Archived from groups: ibm.ibmpc.thinkpad,comp.sys.laptops (More info?)

Hi,

I'm having this problem with my ThinkPad T20's cpu heatsink/fan and I
can't figure out how to fix it. The symtom is the cpu fan is on (as
needed) when I'm only runing either with the battery OR AC power
alone. But the laptop is locked up after maybe 10 minutes if I run
both battery (the battery is in the laptop) AND AC power at the same
time. I narrowed this down that for some reason the lockup due to the
fan not running when cpu is hot.

I already did the following but still no luck:

- Take out the heatsink/fan assembly and clean it good.
- Re-seat the cpu.
- Apply new thermal pad to the cpu.
- Clean the inside of the laptop of any dust.

I'm running Win2K on this machine with all correct drivers and IBM
power management software. Also, the charging unit in the laptop
works fine and correctly charges the battery to full (an old battery
but still can hold a little over 2 hours of power). Any help would
greatly appreciated.

Mike
Anonymous
a b D Laptop
a b à CPUs
September 14, 2004 2:07:49 AM

Archived from groups: comp.sys.laptops (More info?)

The T20 has a problem with too big of a gap between the heatsink and the
lug. this is because it was meant for a "pad" rather than grease, but the
pad will deteriorate over time, and is not very efficient,
What some folks have done is either:
Replace the fan assembly with one from a T21. This has a more massive heat
sink and comes into closer contact with the CPU
or
Put a metal shim between the lug and the heatsink to tighten up the gap, and
use good thermal grease, I find the Arctic Silver works well.
Also blow out the fan, there is probably lots of dust in there which can
slow it down.
"Mike" <mike_2004z@hotmail.com> wrote in message
news:4d5437c6.0409122143.4f06efc0@posting.google.com...
> Hi,
>
> I'm having this problem with my ThinkPad T20's cpu heatsink/fan and I
> can't figure out how to fix it. The symtom is the cpu fan is on (as
> needed) when I'm only runing either with the battery OR AC power
> alone. But the laptop is locked up after maybe 10 minutes if I run
> both battery (the battery is in the laptop) AND AC power at the same
> time. I narrowed this down that for some reason the lockup due to the
> fan not running when cpu is hot.
>
> I already did the following but still no luck:
>
> - Take out the heatsink/fan assembly and clean it good.
> - Re-seat the cpu.
> - Apply new thermal pad to the cpu.
> - Clean the inside of the laptop of any dust.
>
> I'm running Win2K on this machine with all correct drivers and IBM
> power management software. Also, the charging unit in the laptop
> works fine and correctly charges the battery to full (an old battery
> but still can hold a little over 2 hours of power). Any help would
> greatly appreciated.
>
> Mike
!