Asus P7P55D not posting, no beeping and no bad lights

Hi,

So I have a P7P55D-E LX motherboard with an i760 and 8 gigs of 10666 DDR3 Gskill Ripjaw memory. Everything with my system was working fine until I was in my case and I guess I touched the 24pin power connector and the system shut down.

Now the system won't post. The fans come on the sb_pwr light comes on and stays on like it should. The MemOK! light is off as I think it should be. I don't have a CPU light on my model. I don't get any beeps (I have the speaker connected) and nothing happens, it just runs as if the system was idle (no restarting etc).

I've tried resetting the CMOS, using only 1 stick of ram then 2, putting them in different slots and that doesn't help. I took the motherboard out of the case and tried running it bare and still nothing.

I am really confused, please any advice?
8 answers Last reply
More about asus p7p55d posting beeping lights
  1. You were fiddling in the case with the power on???

    Depending on what you were doing, that could be anything from loose cables to critical hardware fail.

    You said you took the MB out and ran it bare, did you completely disconnect/reconnect everything when you did so?

    Safe to assume the speaker was working fine before? Most BIOS's give a single quick beep to notify its POST succeeded and it's ready to boot. If it gave you that before and it's no longer doing anything, that can mean trouble or its connection has gotten loose.
  2. When I took the motherboard out it of the case I completely disconnected and reconnected everything. Right now all I have installed is the ram, CPU and video card.

    The speaker works fine because when I take out the 2 sticks of ram, I get a constant beeping noise. So yes it used to give a quick beep and then post and now it doesn't.
  3. I assume you've tried this already, but did you swap through all your RAM in that first slot when trying to boot?
    It sounds like you managed to short something. Just hoping its simply a stick of RAM and not the motherboard. This kind of thing could also be a sign of a shot memory controller.
  4. Just a shot in the dark but did you try your setup with a different power supply, while it's out of the case?
    I had a system that had a bad PS that would just energize a fan but nothing else.
  5. I thought that too, so I tried a friends PSU which I know works and still no fix.

    In general what would be the symptoms of a corrupted bios or fried motherboard?

    Thanks for all the help btw.
  6. What you're experiencing could be a sign of either something from the MB, CPU, RAM, or any mix of those.
    Something in your system is definitely not cooperating.
    Do you have any means of testing this ram outside of your current board?

    Examine the motherboard extensively for visible damage. Things like broken traces, broke/leaking caps, etc.

    It may also be worth taking out your board and going through the CPU installation procedure all over again. Examine the CPU and socket for any visible damage. I know you've had this CPU in there for a while without problems, but its worth trying. Also reset the CMOS again when you do this.
  7. I was able to get a second motherboard to test my compenents and turns out the problem is the motherboard since everything worked. I've contacted Asus for an RMA to get a new board.

    Thanks for the help on this.
  8. No problem.

    Hopefully the new board will work out for you.
    Best of luck out there .... and try not to poke around inside the case when it's powered on again :/
Ask a new question

Read More

Motherboards Light