Sign in with
Sign up | Sign in
Your question

Rosewill wireless adapter RNX-G300EX not picking up wifi signal. why?

Last response: in Wireless Networking
Share
April 29, 2010 11:00:31 PM

so I decided to get rid of my 100 foot Ethernet cord and get a wifi card instead.
I inserted the card into the first pci slot and installed the driver.
well everything seems to be in working condition except that the card is not picking up signal from my at&t router.
I know I have signal in this spot because my ipod and a laptop can pick it up just fine, but yet the card will not. help me please.
April 29, 2010 11:05:13 PM

oh, and im using windows 7 64-bit.
also the wireless card does show up in network connections but everytime I try to enable it it says it enables it but the icon still stays gray and says its not enabled.
Anonymous
April 30, 2010 4:12:06 PM

Does the driver say specifically that is for 7/64 ?
If it does try some of the following:

If you have a spare PCI slot, move it. Also go into BIOS and see if disabling any ports not in use helps -- candidates are COM ports, Game/Midi, Parallel printer port (if any) if you are using USB printer.

Restart Windows a couple of time and it may clear some resources.
Related resources
May 4, 2010 10:27:09 PM

I already have tried using different pci ports.

yes the driver is specifically for windows 7 64 bit.

no bios is not disabling and ports and I have restarted the computer a million times to no avail.
Anonymous
May 5, 2010 8:43:29 AM

Maybe a hardware fault with the wireless adapter -- can you try it in another computer ?
Anonymous
May 5, 2010 8:43:30 AM

This topic has been closed by Fihart
Anonymous
May 5, 2010 8:46:23 AM

This topic has been reopen by Fihart
Anonymous
June 1, 2010 9:36:08 AM

Quote:
This topic has been reopen by Fihart



I had the same issue before. I reinstalled windows then it work.

Today I tried to move it to another PCI slot and it cannot be enabled, no matter whatever I do.

I'm using windwos 7 64 bit.
Anonymous
June 1, 2010 9:56:06 AM

Finally I found this solution:

Right click on the wireless adapter and go to properties.
Look for a kaspersky or aod protocol and disable them.
restart the computer and it should work.
Thanks
SirSkippy
http://www.sevenforums.com/network-sharing/57707-wirele...

It works in my case.
!