External Hard Drive not recognized by Asus A5A97

I replaced a WD Elements external drive with a Seagate 3.0 hard drive and now my machine won't recognize it when it boots up. It will acknowledge and use it if I unplug it and plug it back in, but not on start up.

To make the WD (1st) drive work I had to disable USB Legacy Support. I assumed I would just plug the new one in and it would work. That is not the case. I've chased a lot of threads looking for answers and none seem to resolve my problem.

I have even taken device manager and uninstalled all USB devices and let them reinstall on start up. Still doesn't see the drive.

I took the original WD and put it in the chassis. Would that have changed anything?

I have tried it with Legacy support on and off, no luck.

The new Seagate 3.0 3TB drive is plugged into the blue colored usb ports on the back of the machine.

What do you think may be the answer. It worked once so it will work again. I just can't figure out how.

I have an Asus A5A97 motherboard.

Thank you for your consideration.
3 answers Last reply
More about external hard drive recognized asus a5a97
  1. page 2-17 for external usb connector then see page 2-32 for the usb 3.0 specs need driver and only work as data storage http://ca.asus.com/en/Motherboards/AMD_AM3Plus/M5A97/#overview
  2. Sorry I haven't responded sooner. I installed the software but, my machine is still not recognizing the drive.
    I haven't had time to uninstall and then reinstall yet. Maybe there was some conflict happening at the time of install.
  3. be around for result
Ask a new question

Read More

Hard Drives Western Digital External Hard Drive Storage