PLEASE HELP! IS MY SSD DYING?

Hi guys,

I've had a problem with my computer since the day I built it pretty much. It was BSODing with the error "INTERRUPT_EXCEPTION_NOT_HANDLED" with various different error codes. I thought it might be the CPU going bad, but it turns out that after I swapped out Corsair RAM for Kingston RAM the system became a lot more stable. I later found out that although it would probably work, the Corsair Vengeance RAM wasn't officially supported with my motherboard (Asus Rampage 3 Black Edition).

However, now I will get random system shutdowns and my system will restart only to try and boot from my storage drive, a 1TB Western Digital. I go into the BIOS and it's swapped my drive order around, putting the SSD as number 2 and the Storage as number 1.

What could this be guys?

Remember, my motherboard does not have native Sata 6gbps support, or native USB3.0 support. As it's an X58 platform each component needs its own hardware controller.
2 answers Last reply
More about please help dying
  1. the shutdown could be an overheat issues or a power supply issue. chp-z and hardware monitor will tell you your temp and power supply voltages. most ssd may have a power loss feature in the firmware. as it a ssd there no moving parts but the drive need good voltage to read and write. have you tried the vendor ssd tools to se if it sees your ssd. you may need to an erase if it finds a bad error.
  2. You have an excellent PSU, but does not hurt to verify your Voltage (UNDER LOAD).

    Cardinal rule – NEVER update MB BIOS, Update firmware, NOR load an operating system without first verifying that the RAM is error free – ie run memtest86 from a bootable cd first.

    Next, the Agility III will work fine on the Sata II port on your X58 MB!!. In fact it works just as WELL as if it was on a sata III Intel port. This was documented in a review, and I have verified on my system (Have two 120 gig agility III SSDs. Just make sure the MB bios is also Up to date! Reason I call the Agillity III a SATA II SSD with a SATA III Wrapper - LOL And yes, I do NOT recommend the Agillity III unles it is all that you can afford.

    Based on your problems, you probably have some files/drivers that are corrupted. This happens when during a write, the write operation is interrupted. Also with possible memory errors the data inside the file/driver could have been hosed.

    Recommend you visit OCZ website:
    1) Verify that you have the Latest firmware. Pre 2.13 was buggy.
    2) You should do a secure erase (need to delete all partitions on the SSD first).
    3) Reinstall the OS – DON’T forget, set Bios to AHCI and DISCONNECT all HDDs during the OS Install


    ADDED: How much free space do you have on the SSD. You have a 60 gig, which means you only have about 56 Gigs usable of which you MUST NOT use more than about 45->50 gigs. Must leave 10 -> 15 % free so thaT WEAR LEVELING, cg, AND tRIM CAN DO THEIR MAGIC.
Ask a new question

Read More

SSD Storage