Sign in with
Sign up | Sign in
Your question
Solved

Problems with Unreal 3 Engine Games

Last response: in Graphics & Displays
Share
March 19, 2010 3:59:26 PM

This is my first post, so hello to everyone out there, and I hope you can help.

I've been having major problems with any game that uses the Unreal 3 Engine. Basically after an indeterminate amount of time the screen will go blank, or blank with vertical dotted stripes, the sound will maybe play for a couple more seconds, then it stops and my computer locks up, forcing me to power it off using the power button. When this happens depends on what my graphical settings are at, but it always happens, and it takes the computer with it, even if I play windowed.

So now, the specs. I'm currently running:

Windows Vista 32bit SP1
Athlon Dual Core 7750 2.7Gig (AM2+)
ASUS V-M3N8200 Motherboard
2*2 Gig Corsair DDR2 800 RAM
XFX HD 4850 with 512 Memory

Things like the sound are all onboard.

So, I've been reading around trying to find out more on the problem and trying lots of different things. So far, I've tried:

Using older drivers (no success)
Checking the temps (the card idles at 40-45 celcius, and I stress tested it with non unreal 3 engine games like CoD:W@W with max settings, the card went to 75 and was fine, the games I'm having problems with don't even tax it that high)
Disabling the onboard sound (no success)
Making a profile using the Catalyst Control Centre to turn off Powerplay (no need, as far as I can tell, the card doesn't attempt to underclock at all, the clock values remain constant).

The only thing that I can remember being mentioned that I've not tried is underclocking the card myself. I think I remember reading that XFX slightly overclocks the card, but CCC gives me no option to go below the value it's set at, I can only overclock. I tried Rivatuner but it says it doesn't support my driver (10-2).

So I think that's everything. I'd appreciate any and all help you can give, and I apologise if this has been answered before, but I'm just having no luck finding a solution anywhere. The main thing I want to know is what the safest way to underclock my card is. I want to try everything I can before I give up on it.
March 19, 2010 5:01:03 PM

What resolution are you playing on, and what detail settings? Could it be your GPU is running out of frame buffer (Video RAM)?
m
0
l
March 19, 2010 5:15:53 PM

Well, full screen is 1280*1024, Anti-Aliasing and Ansiotropic Filtering are both at 4*. Graphic options ingame vary. I've tried playing with them all on their lowest settings, it only helps prolong the inevitable.

The thing is, wouldn't this happen with other games if it was a video RAM problem? As I said I was able to play CoD:W@W at full settings no problems. I did the same with Left 4 Dead 2 and was able to play it for a lot longer that I would be able to play any of the Unreal 3 Engine games which barely last longer than 5-10 mins if I dare even try them at max settings.
m
0
l
Related resources
March 19, 2010 5:17:48 PM

Hmm.. at that resolution, you really shouldn't be running our of Video RAM. Seems really strange that you are having problems JUST with UE3. Have you tried uninstalling and reinstalling those games? Maybe try a full re-format and fresh install of windows too. Seems more like a software issue than a hardware issue if its ONLY those games that do it.
m
0
l
March 19, 2010 5:24:27 PM

I've uninstalled and reinstalled the games several times. If at all possible, I'd prefer if I could find a way that doesn't involve me having to reformat and reinstall everything, it's a lot of work that might not be needed.

Still it's something to consider if I can't find a solution.
m
0
l
March 19, 2010 5:28:16 PM

Thats the only solution/ thing to try, thats coming to mind, because I can't come up with any other reason that ONLY unreal 3 engine games are crashing. I can't think of a single hardware issue that would ONLY affect those games and no other ones.
m
0
l
March 19, 2010 5:53:22 PM

Well, the main reason I'm a bit reluctant to reformat, apart from the obvious having to back up everything I want to keep and then all the work of setting up the computer again, is because I do hope there is another reason to fix it.

As I mentioned in the first post, the problem I'm having was, or possibly still is, quite common. One of the mentioned fixes was to underclock the card, because supposedly the U3Engine is highly sensitive to any overclocking, and if I remember correctly XFX slightly overclock the card for their factory settings.
m
0
l
March 19, 2010 7:08:28 PM

Just there, I tried disabling the AMD Cool n Quiet incase that might have been the problem. Game crashed just like before but this time I almost thought it took my computer with it for good. When I tried starting it up the screen was messed up, like there was a problem with the graphics card, and it wouldn't start up properly. I had to unplug it and plug it back in for it to work again.

The idea of a reformatting and a fresh reinstall is suddenly more interesting.
m
0
l
March 19, 2010 7:58:03 PM

Yeah- That is a strange deal... there are plenty of other games/engines that ought to stress your video card much more than U3E. I mean- run something like Furmark burn test and see if its stable- if that doesn't cause a crash its really gotta be something software related to that engine's interaction with your PC.
m
0
l
March 19, 2010 10:02:37 PM

I just ran a stability test using Furmark for 30 mins. I've never seen my card get so hot (77 degrees celcius) however it was perfectly fine.

It could be a software issue... but what? I have the k-lite codec pack, I could try messing about with that, but if it is a software problem, why would playing the games windowed make it less likely to happen?
m
0
l
March 20, 2010 4:04:33 PM

No idea, but if you can stress with furmark, how can it be hardware? Furmark will stress your card WAYYY more than any game. I don't know what to tell ya man- its pretty strange to me still. I ould probably just end up reformatting and reinstalling windows if it as me.
m
0
l
March 20, 2010 6:43:39 PM

Well, I'll give reformatting some serious thought, but I'll keep looking, see if there's anything I might have missed.

Also thanks for replying. I must admit I'm a little disappointed, I expected more than one person would help, but I guess that just means they aren't sure what it is either.
m
0
l
March 20, 2010 6:47:30 PM

Yeah- normally when I don't really have a good idea of whats causing a problem I won't post, but I guess I was curious to find out what it was and if we could track it down. Hopefully you can get some more ideas either here or somewhere and figure out how to make it work. Good luck man.
m
0
l
March 20, 2010 9:22:56 PM

To take manual control of your clock settings within CCC, you have to go to the OverDrive page and actually click the LOCK above the check-box where it says, "Enable ATI Overdrive"

Once you do that, you should be able to underclock your card. I think the reference clock settings for the 4850 are 625 core / 900 memory. Worth a shot...

Also, you must be in "Advanced" mode.
m
0
l
March 20, 2010 11:12:54 PM

Umm, I know you're trying to help, but I've already done that, quite a while ago. It won't let me put the slider below the stock value of the card though (which is 650/1050)

Speaking of that though, I tried using it to overclock the card, but even when I move the sliders test the new clocks, and OK it, the clock values don't change. At least, CCC doesn't show any change.

m
0
l

Best solution

March 21, 2010 12:38:42 AM

Then you seriously should contact XFX, because OverDrive is something that should work on any ATI card, regardless of the direction you want to move the sliders.
http://www.xfxforce.com
Share
March 21, 2010 2:37:47 PM

Sorry that was my mistake, the no powerplay profile I had made was interfering with it. The clock values remain the old ones when on idle, and should turn it up when I play a game. However, that still leads to the problem that I can't underclock the card, only overclock it. Also the profile voltages don't change, which I'm a bit worried about.
m
0
l
March 21, 2010 4:31:07 PM

Update: I tried using MSI Afterburner to underclock the card to 625/1000 (from 650/1050), however the moment I pressed apply the screen did the dotted line artifacts thing that the games cause, then the computer hard locked.

Hmmm.
m
0
l
March 21, 2010 4:46:33 PM

Sounds like you have more than one or two software programs running that control the clock speeds on this card, thus they're conflicting. Uninstall them all and start anew with just CCC.
m
0
l
March 21, 2010 4:53:04 PM

I'll try that. I have CCC running but I'm not asking it to control anything, still I'll try that.
m
0
l
March 21, 2010 5:32:58 PM

This is getting silly. I uninstalled all the overclocking programs, uninstalled CCC and for good mesure the display driver, used driversweeper and reinstalled, and yet now I'm not getting CCC. Arrgh what is going on.
m
0
l
March 21, 2010 7:09:30 PM

Update: CCC is back, but now I can't even test the stability of any clocks I might want to try. I've sent a ticket to XFX's support to see what they will say, but regardless, tomorrow it looks like I'll be reformatting and reinstalling. Time to back up everything I want to keep.
m
0
l
March 21, 2010 7:36:45 PM

Tough break man. I'm sorry to hear that you've gotta go through the format and re-install process. Back-ups can be tedious at times, depending on how your system is setup...

I tend to do annual (or bi-annual) Windows formats and re-installs. Of course, I also keep only Windows on my C: partition. Even basic programs, like FireFox or CPU-Z get installed to a different partition. The only thing I ever really have to back-up is my Documents folder. You may wanna consider doing something like that. It really does lessen the pain of the process.

On a lighter note, XFX has always responded to my requests in a very timely manner. If they don't, I call them, and they take care of me over the phone. :) 
m
0
l
March 21, 2010 7:52:07 PM

Normally I do partition the hard drive, but when I made this computer last year, I forgot. Strangely I don't have too much to save that I couldn't just redownload, so it'll just be the whole time thing for reinstalling.

However saying that, I used a program called gpu-z to measure my temps, incase it was the memory overheating. I turned off Catalyst AI, put on The Last Remnant (one of the games that's really been giving me jip), and fiddled with one or 2 options there.

I got to a cutscene that always caused the crash without fail and.... got through it all fine. gpu-z records no temperatures over 60 Celcius so it's not overheating. However, the things I altered are all things I've done before.

Arrgh, this is so infuriating. What is going on?! I'm gonna go back into the game and run it longer see how it holds up.
m
0
l
March 21, 2010 7:57:42 PM

Last Remnant just utterly destroys ATI cards. I've never seen an ATI card that runs it anywhere near as well as even less-comparable nVidia counterparts. That is one of the reasons many people who frequent Tom's asked to have that particular game removed from their battery of benchmarking tests, which they eventually did.

I honestly don't suspect it's a hardware-related problem. I'm inclined to believe it's software-related.
m
0
l
March 21, 2010 7:58:00 PM

Well- you know, maybe reinstalling all your drivers and uninstalling all your other monitoring programs and stuff fixed it. Hope thats the case, but good luck in any case. If you end up having to reformat- I'm sorry.
m
0
l
March 21, 2010 9:00:28 PM

Damn, didn't realise Last Remnant was so bad for ATI cards. It's a shame though because I'm really enjoying it.

I hope I won't have to reformat. I was able to play the game there for almost an hour full screen, which is quite rare. I'm going to have to give other games a try too.
m
0
l
March 21, 2010 9:11:40 PM

Well it's not that the game will break them. They just don't run it very well. At least, they definitely didn't used to... I haven't really heard much about it since not too long after the game was pulled from Tom's bench suite. Another site was using it in their bench suite, too, but I can't remember which it was.

Instead of games, you could always try something generic, like UniGine's Tropics or Heaven benchmark programs. They'll just run, and run, and continue running as long as you want or until the system crashes. They should both stress the card at 100% load the whole time, too. And, they'll run windowed so you can monitor temps as it runs. Could use FurMark, too, but that program heats cards up in an unnatural manner.

If this problem occurs in one of these, as well as your Unreal 3 Engine games, then there's something seriously off with that card or your software.
m
0
l
March 21, 2010 10:11:01 PM

I've run furmark a couple of times using the stability test and it had no problems. I also played Batman: Arkham Asylum there and got past the point it crashed at before with the same settings.

The only real thing I can think of is the driversweeper thing. I had it check for nvidia drivers and lo behold it found one, which at first I thought was strange... then I remembered that this motherboard has an onboard gForce which I disabled as soon as I made the computer. Why the driver was there I don't know... I can only wonder if that fixed it.
m
0
l
April 7, 2010 10:38:32 PM

Best answer selected by Zonino.
m
0
l
Anonymous
July 21, 2010 11:27:04 AM

i have problem with that too.. i have GeForce 9600 gso.. and same thing happens every time.. it started with Last Remnant.. and from then it happens with Alpha Protocol, Ghost Worrior, Batman... i cant se solution in this posts.. so can anyone help me?
m
0
l
!