Sign in with
Sign up | Sign in
Your question

Rampage III Extreme not starting

Last response: in Motherboards
Share
December 16, 2010 8:14:18 PM

So I just got a new PC on Monday. I had it built instead of building it myself due to circumstances, was working spectacularly but I didn't like the wiring job, everything was just dumped in front of the mobo, so today I decided to rewire it. I made sure I was grounded, made sure the power was off and unplugged and all that, and did the job, routing as much as I could through the back. I also connected the 3 case front panel USB ports that the store didn't bother to connect. Now the computer won't start. At first I was getting maybe a second where the LED fans would start up, then shut down. Now the power button doesn't do anything at all.

My specs:

Rampage III Extreme Mobo
i7 950 CPU
Corsair H70 CPU Cooler
Corsair XMS3 RAM 12 GB (6x2, got 2 packs of CMX6GX3M3A1600C9, since together they were cheaper than the equivalent 12GB pack)
EVGA GTX 460 EE
Corsair AX1200 PSU
Western Digital 500GB HDD (WD5001AALS)
Thermaltake Element V Black Edition Case

Also, thinking it might be the power supply, I tried turning it off and disconnecting it, but then I noticed that my motherboard stayed lit for at least 6-7 seconds after turning off the power supply (the RoG logo that glows and the start/reset buttons). Not sure if this is supposed to happen or not, as I never stuck around to pay attention to that when shutting down my computer earlier this week. I've tried pressing the start and reset buttons on the mobo, but nothing happened then either.

I saw some older posts about a similar problem where the most common solution is to breadboard the mobo...I have no idea how to do that, or how that would even work.

Any help?
December 19, 2010 12:58:56 PM

firstly check your power supply if it ok then check your mobo and see all wires that correctly plug in.but i think its psu problem.check another psu may be it work.
December 19, 2010 3:19:11 PM

The wires are all plugged in correctly. Removing the mobo battery for about 5-10 minutes didn't help either (this battery explains why there is still a charge for a couple of seconds when the power supply is off).

I doubt it is the power supply, as it gives power to the motherboard when I turn it on, but I will check as soon as I can. I don't happen to have another one to test with, but I can still test that one on its own. Will post results as soon as possible.
December 19, 2010 8:03:38 PM

Using a paperclip as a jumper, the power supply works. Didn't happen to have a multi meter on hand to truly test it, but the fans spin and the case fans I had connected also spin.
!