Sign in with
Sign up | Sign in
Your question

Spark from Mobo...

Last response: in Systems
Share
April 8, 2010 8:56:40 PM

Hello Everyone,

I finished putting together my build today. Went and double checked to make sure everything was plugged in and good and it appeared to be. Hit the power button and the LEDs flashed on the fan and on the mobo quick and the fans took about a quarter turn then everything turned off. So then I unplugged everything unnecessary. I left the CPU/Heatsink, Ram, GPU, and the wire leading to the power switch. Tried turning it on like that and then there was a blue spark from the motherboard... Any ideas on trying to see if it's dead or should I just try sending it in?

More about : spark mobo

April 8, 2010 9:01:31 PM

mb is dead, it should NEVER spark even if it's bad, as an added bonus you may have burnt out everything attached to it, or nothing if you are a lot luckier than i
m
0
l
April 8, 2010 9:06:56 PM

^^^ +1
m
0
l
Related resources
April 8, 2010 9:43:34 PM

My advice is to just RMA/return everything unless you have another system handy to test individual components.
m
0
l
April 8, 2010 10:17:18 PM

Im going with replacing the equipment that was attached with it when it sparked since I don't have another system handy to test anything. Still don't get why it sparked though... I took it out of the case and put it on a non conductive surface with only the minimum like I have read to do at couple places.
m
0
l
April 8, 2010 11:22:47 PM

manufacturing defect, or severe miss handling
m
0
l
!