Sign in with
Sign up | Sign in
Your question
Closed

Installed liquid cooling loop, now comp doesn't... do anything.

Last response: in Overclocking
Share
February 27, 2013 4:21:23 PM

Hi everyone, I have a home build that's been working perfectly for about a year and a half now, so I decided to try installing a liquid cooling loop. I got the loop installed and let the system sit without power for a full 48 hours just to ensure that any water that may have spilled that I wasn't able to clean up would evaporate, then I plugged it back in and tried to power up but nothing happened. The little Power and Reset buttons on my DX58SO2 motherboard are lit up, so I know the system is getting power, but when I press the main power button on my case or either of the Power or Reset buttons on my mobo literally nothing happens. No fans, no lights, not even a *click*. It's like it's not even trying.

Does anybody have any idea what might be going on here? I'm at a total loss to think of what would be causing it to fail without showing any indication of trying to boot first.

Thanks so much for the help!
February 27, 2013 4:44:24 PM

Try rewiring or something. If you spilled any water on it at all it could be damaged, make sure your power supply has enough room for all your components + the new loop.
Score
0
February 27, 2013 4:46:33 PM

Maybe you did not plug in the cpu fan, some motherboard do not on if the cpu fan is not plug in.
Score
0
February 27, 2013 4:49:08 PM

Thanks, I'll try, but I'm not sure wiring is the issue. I left all the wiring intact but just removed power to the system by unplugging my PSU from the wall outlet and then I used an auxiliary PSU to test and fill the loop, so I don't think anything should have changed in that regard.
Score
0
February 27, 2013 4:52:19 PM

That last post was @athulajp.

@pete, I thought about that a little while ago and plugged my top case fan into the CPU Fan socket on my motherboard, but still no luck. :( 
Score
0
a c 329 K Overclocking
February 27, 2013 5:36:13 PM

Can you describe what is in the loop or link to the components? Is this a closed loop cooler or an actual watercooling loop you had to assemble and fill?
Score
0
February 27, 2013 5:46:08 PM

It's an actual loop that I had to assemble and fill. Components are listed below:

Pump: Swiftech MCP35X
Res: Swiftech Maelstrom SPH (single pump housing)
GPU Block: EK-FC580 GTX
CPU Block: EK-Supremacy
Radiator: Phobya Xtreme 200 (245x200x36mm)
And I'm just using straight DI water (with biocide) as the coolant.

Thanks
Score
0
a c 329 K Overclocking
February 27, 2013 7:02:41 PM

Is the PSU still jumpered and not connected to the ATX plug on the MB? It's also possible that you had a leak and the MB has shorted. Have you disconnected the PSU or reset it and attempted again?
Score
0
February 27, 2013 7:40:39 PM

I actually have two PSU's: I have the PSU that's been powering my computer that I left connected to all my components, but that I disconnected from the wall outlet so that there is no power to the system. Then I had an extra PSU that I've been using exclusively to test and fill the liquid cooling loop so that that system was completely isolated from all the other electronics as a failsafe in case there was a leak.

I haven't tried disconnecting and reconnecting the PSU though because I had just left it connected the way it was before I installed the liquid cooling system and it was working. Do you still think it might be worthwhile?

Also, I know there's no way for you to know for sure, but based on your experience, in the event that I did have a leak and the mobo shorted, what are the odds that it's completely compromised? If it did short will I most likely need a new motherboard, or could it be salvaged?

Thank you (and everyone) so much for your help!
Score
0

Best solution

a c 329 K Overclocking
February 27, 2013 8:21:46 PM

Ok, that helps.

I would first start by disconnecting your main PSU from power (unplug) for a minute, then plugging back in and powering on. It's possible that it went into some sort of failsafe mode. Mine does that if there is a power outage and needs to be reset to power on.

If you had a leak, hopefully it would have completely dried before you powered on the main PSU. Distilled water is technically non-conductive, but any liquid will become conductive after a short time in direct contact with metals. I've had water leaks and drips before and letting it dry completely overnight before powering on usually fixes the issue. I recommend a can of compressed air/dust spray and a desk fan to help force evaporation.

Also, if you were leak testing, I would assume you were very diligent in looking over every connection throughout the loop to ensure there weren't any leaks.
Share
February 27, 2013 9:15:17 PM

Thanks for your help. I thought I was thorough about making sure the loop was tightly sealed, but I suppose anything is possible. I'll try resetting my PSU then leave the whole system under some fans overnight and see if that helps at all! Post the results to let you know whether it worked or not.

Thanks!
Score
0
February 28, 2013 11:50:22 AM

No dice. I left the whole system in front of a window fan all night with CPU and GPU removed, put everything back together and tried again, but still nothing. I'm thinking I may be on the market for a new motherboard... :(  Either that or a new PSU, but when I jumper the PSU it still has enough juice to power the case fans and HDDs, so I don't think that's the culprit.

Any last ditch efforts anyone can think of before I bite the bullet and buy a new motherboard?

Thanks for the continuing help!
Score
0
a c 329 K Overclocking
February 28, 2013 12:19:11 PM

A PSU can still power your peripheral components but might not be able to trigger the ATX power to the board...I've actually had this before and thought it was MB and not PSU. You might try your extra PSU and see if you get a different result, if not, you might actually have a board issue.

Have you also checked the mounting/backplate for the CPU block to make sure it's not shorting on the board?
Score
0
March 6, 2013 11:26:44 PM

I tried using my main power supply to power the peripherals and my alternate power supply to power the board but still no luck, so I just ordered another motherboard and we'll see what happens! Thank you all for your help!
Score
0
March 6, 2013 11:27:12 PM

Best answer selected by wba4493.
Score
0
a b K Overclocking
March 7, 2013 2:09:01 AM

Can you try the screwdriver trick to trigger the motherboard incase something went wrong with the case power button.
Score
0
March 7, 2013 11:04:52 AM

What's the screwdriver trick? I've tried the power button on the motherboard as well as the case power button, but at I'm open to trying anything...
Score
0
a b K Overclocking
March 7, 2013 5:09:43 PM

wba4493 said:
What's the screwdriver trick? I've tried the power button on the motherboard as well as the case power button, but at I'm open to trying anything...

Short the switch contacts with a screwdriver but since the motherboard button does not work then it probably will not work.

I would try reseating the PSU ATX (both the 20 pin and the cpu) connectors and if that does not work it looks like you need a new board.
Score
0
a b K Overclocking
March 7, 2013 5:11:57 PM

wba4493 said:
What's the screwdriver trick? I've tried the power button on the motherboard as well as the case power button, but at I'm open to trying anything...

Ugh... forum bugs driving me crazy.

It is short the power switch contacts with a screwdriver but since the motherboard button does not work it is doubtful.

At the point I would just try to reseat both the 20 pin and the 4 pin connectors if you haven't already but I think the board is probably bad.
Score
0
a c 329 K Overclocking
March 8, 2013 1:05:16 AM

I'd strongly advise against shorting any contacts with a screwdriver, whether that be an ATX plug or motherboard contacts. This could potentially result in electric shock or even electrocution/death.

Please do not advise others of this action.
Score
0
a c 329 K Overclocking
March 8, 2013 1:06:15 AM

This topic has been closed by Rubix_1011
Score
0
!