4GB available of 6GB total

I built my new computer last night. Everything seemed great...got the 64bit OS installed, etc. etc. At first W7 recognized 6GB and all was good. Then later in the evening I noticed it dropped to 6Gb with only 4GB usable. I rebooted and same thing. Bios had Channel a listed as - marks, so I figured it needed reseated or it was faulty. I reinstalled all the modules and restarted -- back to 6GB. So I figured I must have bumped it out or something. Now its done it again today.

I ran memtest with all three modules in and received the message there were memory problems. I did this when it was reading 4GB or 6GB total. A later test, after again reinstalling the modules, cleared memtest.

I rebooted with a module in a different white slot each time and ran memtest on each on independently. No problems with any of the three. I've reinstalled all the modules and rebooted -- I'm back to 6GB now, but am afraid something is wrong with the mobo, RAM, or processor. Here's my build. Lots of people seem to have this problem, but there doesn't seem to be a clear reason for it. Anyone have an suggestions?

Intel Core
i7-930
Cooler Master V8 CPU cooler
GIGABYTE GA-X58A-UD3R mobo
AZZA Fantom 900 case
Antec 750W True Power
Western Digital Caviar Black 1TB 7200 RPM SATA 6.0Gb/s
SAPPHIRE 100290SR Radeon HD 5870 (Cypress XT) 2GB
G.SKILL 6GB (3 x 2GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800) Triple Channel
10 answers Last reply
More about total
  1. Check the BIOS for an option to enable triple channel.
  2. The following are the DD3 1600 Modules that your mobo supports
    GSET16C1 2GB G.SKILL F3-12800CL9D-4GBNQ DS v 3PCS
    GSET16C2 2GB G.SKILL F3-12800CL7D-4GBECO DS v 6PCS

    You'll need to check if it's one of them.

    Then, also update the BIOS from here
    http://www.gigabyte.com.tw/Support/Motherboard/BIOS_DownloadFile.aspx?FileType=BIOS&FileID=15695

    That has a fix in it for your problem, I think.
  3. mosox said:
    Check the BIOS for an option to enable triple channel.

    There is no option in the BIOS to "enable" triple channel. That's determined by putting the RAM in the correct RAM slots. Did you manually set the RAM speed, timings, and voltage to their rated specs in the BIOS? That's the first thing I'd do. You can run Memtest86+ again after you've got the values set correctly.
  4. The New Gigabyte Bioses Fix All Memory problems that I've seen.

    Good Luck :D
  5. Nah, it didn't fix a thing. I updated and still the same problem. I believe it has to do with the coolermaster V8 either being too tight or a bent pin in the motherboard. I hope not.
  6. I have a BIOS dual channel option, it's called "ganged mode". Gigabyte GA-MA790X-UD4 (AM2+).
  7. mosox said:
    I have a BIOS dual channel option, it's called "ganged mode". Gigabyte GA-MA790X-UD4 (AM2+).

    Intel chips have no such limitation. If you put the right number of sticks of RAM in the correct slots then dual/triple channel mode is automatically turned on.
  8. As others and yourself stated: probably either a BIOS or hardware issue. However, it wouldn't hurt to boot up something like Knoppix live cd and see what it reports.

    If it is a hardware issue you might get a lot of kernel panics, too. The O/S may try reading and writing to memory addresses that do not physically exist anymore because the hardware slot connections are okay for a second and then memory disappears because of a bent pin or what not.

    You may want to enable a total memory count on boot too. That way if the BIOS counts 6GB and the O/S shows only 4GB there is probably something screwy with the o/s. Or if the BIOS is only counting 4GB it may be a hardware issue.


    EDIT: I'd get a can of compressed air and thoroughly lean the slots and pins too.
  9. I talked with the Gskill tech support on their forum and they had me RMA the sticks. I'm receiving the replacements tomorrow, so I'll update with how they work after I test them out. Thanks for all the replies. Hopefully it was just faulty sticks, but I'm not convinced.
  10. Good for you if it works fine with the new sticks, keep us posted anyways.
Ask a new question

Read More

Homebuilt Systems