Sign in with
Sign up | Sign in
Your question
Solved

CAT 10.1 will load, CAT 10.2 fails to load display driver

Last response: in Graphics & Displays
Share
March 21, 2010 1:33:00 AM

Hey Forum,

I am having a problem loading CAT 10.2 for my AMD system. It will load 10.1 just fine. I use driver sweeper and try to load CAT 10.2 and I get display driver failed to load.

AMD 955 BE
Gigabyte GA-MA785G-UD3H
8 GB G Skil 6400
XFX HD 5770
Rosewill 550 watt PSU

I have no problem loading CAT 10.2 with my Intel system. Seem to run sweet.

Intel Q9550
Gigabyte GA-EP45-UD3P
8 GB OCZ Blade 6400
2 - XFX HD 5770
BFG 650 watt PSU

I'm pretty sure BIOS is up to date on both machines. The AMD machine runs OK with CAT 10.1, but I get the gray screen occasionally, just enough to irk me. I was just wondering if anyone else has had this problem?

I usually game on the intel machine, I am running three monitors, with no Displayport, so I enable crossfire to game with and drop down to one monitor, and use three when not gaming in non-crossfire mode.

Any help would be appreciated.

Best solution

March 21, 2010 2:16:58 AM

Hmm, you didn't remove the Chipset drivers when you ran driver sweeper, correct?

Also, you could try the preview driver (10.3a) just to see if it will install.
Share
March 21, 2010 11:24:36 AM

EXT64 said:
Hmm, you didn't remove the Chipset drivers when you ran driver sweeper, correct?

Also, you could try the preview driver (10.3a) just to see if it will install.


Thanks for the help. I reinstalled the chipset drivers, and then tried 10.2 again with no joy. I then tried 10.3a and it worked like a charm. After reading the update notes, I installed it on my Intel machine, and ran Unigine Heaven Benchmark.



A marked improvement over 10.2. I picked up 7 FPS and 166 points to overall score.

Thanks again for the headsup on the preview driver. (grinning ear to ear)

:bounce: 
m
0
l
Related resources
March 21, 2010 11:27:44 AM

Best answer selected by henrystrawn.
m
0
l
March 22, 2010 12:20:15 AM

Well, glad you got it working. Who knows what was wrong with the 10.2s.
m
0
l
!