Sign in with
Sign up | Sign in
Your question

How to Optimize my system.

Last response: in Overclocking
Share
March 1, 2013 5:51:38 PM

Hi everyone, new to the forums, and was needing a little help to optimize my new build for best performance. I really don't think I need to overclock my system or anything I just think there are some settings that I could probably turn on that may make my system run better. I don't know much about bios settings. Here is my build.
COOLER MASTER HAF X RC-942-KKN1 Black Steel/ Plastic ATX Full Tower Computer Case

ASUS Maximus V FORMULA LGA 1155 Intel Z77 HDMI SATA 6Gb/s USB 3.0 Extended ATX Intel Motherboard

Intel Core i7-3770K Ivy Bridge 3.5GHz (3.9GHz Turbo) LGA 1155 77W Quad-Core Desktop Processor Intel HD Graphics 4000 BX80637I73770K

G.SKILL Ripjaws Z Series 16GB (2 x 8GB) 240-Pin DDR3 SDRAM DDR3 2133 (PC3 17000) Desktop Memory Model F3-2133C11D-16GZL

Kingston HyperX 3K SH103S3/120G 2.5" 120GB SATA III MLC Internal Solid State Drive (SSD) (Stand-Alone Drive)

Western Digital WD Black WD1002FAEX 1TB 7200 RPM 64MB Cache SATA 6.0Gb/s 3.5" Internal Hard Drive -Bare Drive

CORSAIR Hydro series H50 High Performance CPU Cooler



More about : optimize system

a b V Motherboard
a b K Overclocking
March 1, 2013 6:09:03 PM

What do you use the system for?
March 1, 2013 6:10:51 PM

Mostly gaming
Related resources
a b V Motherboard
a b K Overclocking
March 1, 2013 6:18:32 PM

Have you got a graphics card?
March 1, 2013 6:46:54 PM

Sorry forgot to post that, guess that's pretty important.


EVGA SuperClocked+ 03G-P4-3663-KR GeForce GTX 660 Ti 3GB 192-bit GDDR5 PCI Express 3.0 x16 HDCP Ready SLI Support Video Card
a b V Motherboard
a b K Overclocking
March 1, 2013 6:49:58 PM

well other than overclocking the only thing i could think of doing is seeing your ram speed and timings are set correct, other than that you will max out any game you want so no worries there
March 1, 2013 7:03:49 PM

I am at work right now, when I get home I can write down what they are at and post it. I don't know if it is or not. I was trying also to run stress tests to make sure cooling was ok. I ran prime 95 for about 15 minutes and it seemed the hottest it got was 85c. I was told though to check and make sure the pump is at full power all the time on the h50. I have it connected to a fan header cha fan 2. And I went into bios and it said that it was set to standard. So I'm guessing that's normal or is there another setting?
a b V Motherboard
a b K Overclocking
March 1, 2013 7:52:06 PM

No you will need to disable fan control if you connect the pump there
March 2, 2013 1:30:36 PM

I didn't have a disable option I had quit standard and turbo, I put it on turbo. Hope that works
a b V Motherboard
a b K Overclocking
March 2, 2013 3:05:43 PM

not really it would be better if you connect it directly to your psu
March 2, 2013 3:16:54 PM

Ok thanks, ill do that when I get home.
!