Asus P5B power “On and Off cycle” problem

Asus P5B power “On and Off cycle” problem.

Hi everybody,

A few days ago, and while trying to power on my Asus P5B based computer, I noticed when I press the power button, the CPU fan spins for 3 seconds and then powers off. It stays off for 2 seconds and then it tries to power on, and again it stays on for 3 seconds and then off for 2 seconds and cycle continues! On 3 seconds, Off 2 seconds ..... No post. No beep. Very strange!

My first thought was the Power supply. I tried two different power supplies. Same results.

I then proceeded, one by one, to remove the all sata drives, video card and memory sticks. Same thing.

Replaced the CPU and CPU fan. Again, No change.

I tried bypassing the power switch by powering on the board by shorting the power pins on the motherboard. Same thing

The only thing remained constant was the motherboard. Clearly the problem is there, so I tried
removing and then reinstalling the battery and resetting the CMOS using the jumper method. No success.

One more thing that might shed some light on the problem. When I remove the 4 pin EATX (12V) connecter and then try to power on the motherboard with only the main power connector, this time, the CPU fan spins constantly but no beep and no post and no “on and off” cycle.

Any ideas? Is the the motherboard toast? I am baffled!

Thanks in advance for your input!
3 answers Last reply
More about asus power cycle problem
  1. i have the same problem, i'm sorry for bumping up this thread, please help me.
  2. You wrote that you get no beeps, therefore I presume that a speaker is installed and that the motherboard used to beep at POST. Did you test the motherboard out of the case (CPU only)? The 4 pin ATX 12V connector needs to connected; otherwise the CPU gets no power.

    @exodia8080, unless you have the same motherboard and you performed the same tests, you should probably create a new post.
  3. abrams said:
    Asus P5B power “On and Off cycle” problem.

    Hi everybody,

    A few days ago, and while trying to power on my Asus P5B based computer, I noticed when I press the power button, the CPU fan spins for 3 seconds and then powers off. It stays off for 2 seconds and then it tries to power on, and again it stays on for 3 seconds and then off for 2 seconds and cycle continues! On 3 seconds, Off 2 seconds ..... No post. No beep. Very strange!

    My first thought was the Power supply. I tried two different power supplies. Same results.

    I then proceeded, one by one, to remove the all sata drives, video card and memory sticks. Same thing.

    Replaced the CPU and CPU fan. Again, No change.

    I tried bypassing the power switch by powering on the board by shorting the power pins on the motherboard. Same thing

    The only thing remained constant was the motherboard. Clearly the problem is there, so I tried
    removing and then reinstalling the battery and resetting the CMOS using the jumper method. No success.

    One more thing that might shed some light on the problem. When I remove the 4 pin EATX (12V) connecter and then try to power on the motherboard with only the main power connector, this time, the CPU fan spins constantly but no beep and no post and no “on and off” cycle.

    Any ideas? Is the the motherboard toast? I am baffled!

    Thanks in advance for your input!


    Hello, did you ever resolve this? I now have the same problem.
Ask a new question

Read More

Asus Power Supplies Power Motherboards