Can't Connect using Remote Desktop

Hello,
I am having trouble connecting to a computer that's on a local subnet using Remote Desktop Connection (RDC). I get no error message. It starts the process of connecting after I type the IP Address in and hit enter. The address and other info turn grey like always... but then about 2 seconds later it stops and returns to normal. No error message provided. I can ping the server that I'm trying to reach and I can ping my laptop from the server... in fact I can RDC from that server into my laptop... but not the other way... and I really need to once I'm on the road. Anyone have any clues. It seems like it must be a setting or a service not started on one or both. The obvious ones are covered e.g. RDC permissions. I also turned off all firewalls to eliminate that risk too. Nothing works.
6 answers Last reply
More about connect remote desktop
  1. Make sure the version of RDP is the same on both computers.
  2. I'm running different OS's... my laptop runs Vista Ultimate 64-bit while the other runs Server 2003 32-bit... how can I get one or the other to run the same version RDP?... or does this mean it's not possible.

    Since the original post, I found that using TightVNC on both machines has solved the problem but would still prefer to use RDP if possible.
  3. I’m not sure what the problem is, although having different RDP versions doesn't seem likely to be an issue if they are at least compatible server->laptop. Something else seems to be at play here.

    wrt to alternatives, fwiw, I prefer LogMeIn Free. The beauty is that you don't need to manage firewalls, ports, or even open ports at all. Its use of a rendezvous server and support of NAT traversal make all the unnecessary. And that makes your network safer since anytime you have ports open, you're subject to attacks should there be vulnerabilities wrt services available on those ports.

    https://secure.logmein.com/US/products/free/
  4. If you have a third computer, try to connect to the server with that one, and see if your laptop can connect to the third computer as well. You can even try a VMwair if you don't have another computer. That will hopefully tell your what is causing the problem.

    I think something is messed up with the RDP on the Laptop. Just the fact that it doesn't display a error message.
  5. Maybe there's a port conflict. RDP will require a given port on the server side, but the client can use any available port. That’ one thing that's different depending on the direction of access.

    Still seems like a long shot, but it is a remote (no pun intended) possibility.
  6. Nothing seems to have worked getting RDP to operate. Thank you for the suggestions so far. TightVNC is still working.
Ask a new question

Read More

vpn Remote Desktop Connection Networking