Sign in with
Sign up | Sign in
Your question

Razer Mamba causes boot issues

Last response: in Systems
Share
April 14, 2010 8:15:40 PM

I recently bought a razer mamba and whenever I start up my PC with it plugged in, it wont get past POST. It just freezes after it shows my CPU settings and I can't go into BIOS or anything.

Anyone heard of these issues? How can I fix it? Thanks
a b B Homebuilt system
April 14, 2010 10:50:23 PM

Did you look on there website for compatible drivers for your OS ?
April 14, 2010 10:50:30 PM

Yes, I have the Windows 7 64 bit drivers.
Related resources
Can't find your answer ? Ask !
a b B Homebuilt system
April 15, 2010 12:07:26 AM

It could be drawing to much current for your USB ports to supply, try connecting it to the USB ports at the back of your computer, or if that doesn’t work try the ones at the front of your computer. You could also try running it from a powered hub. Another idea try turning off legacy mode for your USB ports in the BIOS if it is on and the ability to boot from a USB device.
If all of this does not work then you probably have a faulty device.
April 15, 2010 12:35:23 AM

Thanks a lot man :)  I'm going to try all of this right now and post back if any of it works in case anyone else runs into this problem.

Not sure if I know how to turn off legacy mode for specifically USB ports, we'll find out.
April 15, 2010 12:38:29 AM

Can't edit my post so I'll double

EDIT: My Mamba has 1000Hz polling for 1ms response time, if I connect it to another USB hub or to my screen/keyboard, will this make it ever so slightly slower?

April 15, 2010 12:49:22 AM

Can't edit again, maybe it's an issue with my browser idk but here's an update

I have just disabled 'Legacy supprt of USB Mouse.', but it hasn't worked, I still freeze when my system tries to detect IDE devices.

Why would it freeze when trying to detect IDE devices? Just after it shows me CPU/RAM Specs.

Also if I plug it in half way while it tries to detect IDE and my AHCI devices it will interupt those and freeze
a b B Homebuilt system
April 15, 2010 2:48:25 AM

Quote:
Why would it freeze when trying to detect IDE devices? Just after it shows me CPU/RAM Specs.
Your computer could be detecting the Razer Mamba as a bootable device, and is waiting for it to respond, try altering your BIOS settings to only boot from your hard drive.
a b B Homebuilt system
April 15, 2010 2:48:58 AM

Quote:
Why would it freeze when trying to detect IDE devices? Just after it shows me CPU/RAM Specs.
Your computer could be detecting the Razer Mamba as a bootable device, and is waiting for it to respond, try altering your BIOS settings to only boot from your hard drive.
April 15, 2010 2:52:25 AM

Don't rule out a defective USB device either... I'm running the same mouse with no issues at all (of course we probably have different MoBo/BIOS ... etc...). Anyway, if all else fails RMA the thing.
April 15, 2010 8:37:15 AM

How do I RMA?

I've never done it.

My product is registered on the Razer website, is that all I need?
April 15, 2010 3:11:56 PM

Hey guys, I just found out the real reason behind it failing to get past POST is when both my keyboard and mouse are plugged into the USB, if it's just one of either it's fine.

Any ideas?

!