Having an utterly IMPOSSIBLE time getting onboard sound to work

NOTE: I originally posted this here -- http://www.tomshardware.com/forum/296107-28-having-utterly-impossible-time-onboard-sound-work -- because I wasn't sure if it qualified as a motherboard or sound card issue, given that it's an onboard sound device.


I'll give as good of a history/explanation as possible for this case. It has been incredibly frustrating and thus far without a solution. About a year ago my motherboard fried and not until this past week did I get it fixed. My last mobo was a Foxconn Geforce 590 sli and I replaced it with an ASUS M4A88T-V EVO/USB3 AM3 AMD 880G. I also replaced the RAM and processor.

Since both boards were 64-bit, I decided to go ahead and use the hard drive I was using before the mobo broke and just plug it in. After getting all the proper chipset, processor, system device drivers installed, everything was working great with my new Asus board. No conflicts and nothing else to change driver-wise according to Driver Agent. That is, except my realtek high definition audio driver. From the beginning I have been getting absolution no sound through any of the jacks in the back of the computer. The frustrating thing is that, according to my Windows audio device panel, I am receiving playback from the card, but absolutely no sound (meaning that the level on the device window goes up and down as I play music, for instance). The onboard sound card for my new mobo is the Realtek ALC892.

Nothing is muted. I have tried a multitude of different drivers, updated chipsets again, and checked every possible setting within Windows' audio settings. Driver Agent still tells me I need to update my sound driver but the one it recommends will not even install correctly as it is SRS. I have tried over and over again to uninstall the Windows drivers and reinstalling the Realtek ones. When that did not work, I repeatedly tried uninstalling the realtek drivers (through both device manager and add/remove programs) and trying again. About every other install, the Realtek audio manager (the program that starts up with the computer and resides in the taskbar on the right; the orange icon, that is) decides to install with it. Other times, it does not. Very arbitrary and inconsistent.

Since I'm getting playback and Asus is a reliable board, I'm not going to jump to the conclusion that the problem is hardware based. It's more likely, I feel, that there's a conflict somewhere between the OLD DRIVERS from my last, broken mobo and the NEW ONES I installed with this new Asus board. I do not know how to separate or get rid of the old ones, however, nor do I know if this is actually the problem. What else could be causing this conflict. Once again, I'm getting NO SOUND AT ALL. No fuzziness or static, nothing. I am receiving playback, however, according to Windows audio.

Could anyone please help me with this? I want to repeat that nothing is muted or anything like this -- I've tried six hours worth of solutions and I'm absolutely certain I did not make some silly mistake like that. I'm open to ideas -- please. Here is my setup:

AMD Phenom II X4 955 Black Edition
Chipset: AMD 785G (RS780) + SB750
4 gigs DDR3 SDRAM
Geforce 7900 GT
8 answers Last reply
More about having utterly impossible time onboard sound work
  1. I have also gone to the device manager and enabled seeing hidden or disconnected devices and deleted those that were no longer pertinent to my new hardware setup.
  2. I would not worry first of all as, in my experience of these things, the problem is software/driver based and will eventually be solved. I would wage that the motherboard and remaining hardware is fine.

    If you havent, enable onboard chipset sound in BIOS configuration.

    You are correct in assuming it is some kind of conflict. Go to 'Run' then type 'cmd'. Type 'set devmgr_show_details=1' hit return. Type 'set devmgr_show_nonpresent_devices=1' hit return. Type 'start devmgmt.msc' and it comes up. Collapse everything, is anything greyed out?
  3. Yea like I said I did this and quite a bit of stuff was greyed out. I uninstalled a lot of it but not all of it. Should I remove everything there that's greyed out?
  4. Recently I installed a new graphics card in my mom's PC. The device manager said I had the latest sound drivers and everything was supposedly operating correctly...but there was no sound.

    Somehow the graphics drivers had turned off the onboard sound. I had to go into BIOS and change the onboard sound from auto to enabled. The sound worked fine after that...very strange.

    Have you tried going into BIOS and making sure onboard sound is enabled?
  5. Yes it is enabled. But it could be possible that the graphics card is causing a problem although I would not know why.
  6. Yes it is enabled. But it could be possible that the graphics card is causing a problem although I would not know why.
  7. Boot from a modern Linux CD to see if you hear sound. If you do, you have a software problem. If you don't, you have a hardware problem.
  8. Thanks rodney, I'll try booting it from Ubuntu and see what happens.
Ask a new question

Read More