Sign in with
Sign up | Sign in
Your question

Insert a Disk into Removable Disk USB Drive Error

Tags:
  • Flash Media
  • Removable Disk
  • USB Drive
  • Storage
Last response: in Storage
Share
May 23, 2012 5:28:24 AM

I've been having an extremely strange error the past 2 days, which has now cost me THREE different USB Flash Drives. For whatever reason it appears as though my laptop after several years is corrupting any drive it writes data to in the past 2 days.

The drives initially show up as corrupted and say they need to be formatted. However, when I try that, it inevitably fails, and from that point on, while the drives are detected (checked on 3 seperate machines) they all give the error:

Please Insert a Disk into Removable Disk [drive letter]

At that point I can't format, or even try to. Disk Management can't change drive letter, can't run Chkdsk, the few error checking utilities I've tried can't detect the drives. I really have no idea what to even try at this point. These are 3 different drives, of different sizes (8, 16 and 32gb) from different manufacturers (OCZ and Patriot). I honestly don't care about any of the data on the drives, but I really want to be able to use them again. It's hard to imagine that they'd be permanently all destroyed unless the laptop has somehow gone fully rogue on me.

Any help greatly appreciated. I'm completely at a loss here

EDIT: I'm desperate for help and nobody seems to be replying. If anyone can successfully help me get the drives working again without having to RMA (I don't care about recovering the data) I'll pay you $25 by PayPal

More about : insert disk removable disk usb drive error

May 23, 2012 5:40:52 AM

To give a bit more information:

When i try to run Chkdsk through CMD i get the error: 'Cannot open volume for direct access'

Within Disk Management I can add/remove/change drive letters to my heart's content, but can go no further afterwards.

When I right click and select Format I get the error 'There is no disk in Drive [letter]'

Looking in Device Manager all the USB drivers seem to be working and up to date, as would also be indicated by 2 other computers having the same problem. I have also tested a 4th USB drive on my main computer and it works without issue, it is just the 3 that were used in the laptop that are corrupted
m
0
l
May 23, 2012 6:17:53 AM

Is anyone able to help? I've searched for just about anything I can find with no success.


Also, has anyone heard before of a device suddenly starting to corrupt any USB device plugged into it after several years of proper operation. I don't even think RMAing these drives is worthwhile, if the underlying problem keeps corrupting the replacements
m
0
l
Related resources
March 18, 2013 7:14:42 PM

Consult an expert as soon as possible.
m
0
l
December 5, 2013 3:20:42 PM

Hi, I just had this problem today and I fixed it myself.
Well, I'm not sure if what I had done before that (searching on the internet and trying several methods: registry, "fix it" by Microsoft; plugging out plugging in.., etc.) contributed to the result, but I just plugged it out, tried to "flip" it lightly, and then it worked..!
I'm so happy that I didn't have to buy a new drive or format this one any more!
Please tell me if it works for you.. Good luck!
m
0
l
!