Sign in with
Sign up | Sign in
Your question
Solved

Not able to use all my memory

Last response: in Memory
Share
December 27, 2010 9:55:49 PM

Hi there, I recently bought a hd5450 and 1 gb of kingston ddr 2 4200 for an Acer pre-build computer back from 2006.
Acer Aspire E500
Specs(before adding the 5450 and 1gb of ram)
Pendium D
1 gb of Nanya ddr 2 4200(756mb usable)
256 mb on-board ati xpress 200 card
Ecs (Elitegroup) RC410-M2 (Me thinks)(P.S. Only two ram slots)


The 5450 worked as soon as I put it in but Windows tells me I have 1 gb of ram when I should have 2 gb. I thought maybe the ram was faulty but when I put the Kingston by itself, Windows still said I had 1 gb. The other ram slot also worked. I put the Nanya by itself and still the same thing. Put both together and I get 1 gb of total ram. At this moment I was like wtf. So I launched CPU-Z and it says I have 2 gb of ram. I open my BIOS to find it had no memory option whats so ever. I updated the bios but the version I had before is the latest version. I'm open to any ideas on how to fix this. Here are some CPU-z Screens if anyone needs it.










p.s: First Post :D 

More about : memory

a b } Memory
December 27, 2010 11:43:00 PM

Welcome, Newcomer. Have you tried disabling the onboard VGA? As you know, the onboard video graphics accelerator reserves a portion of your installed RAM to use for graphics processing. 1 GB could be the max amount it reserves, since you've added more.

As for CPU-Z... CPU-Z is reading the SPD chips on your RAM. The SPD chips contain the info about the RAM sticks, so it's not a surprise that CPU-Z detects 2 GB.
m
0
l
December 28, 2010 12:15:17 AM

thanks for the reply, I'm pretty sure my on-board video card is disabled. I dont see it on device manager, I also checked my bios. The boot video card is chosen as PEG/PCI (I dont know what PEG Is). Frame buffer is at auto(has options such as 32 mb, 64 mb till 256 mb, guess this is the amount of ram the on-board has and theres no 0 option). And Surround View(use the on-board as a secondary GFX) is disabled.
Is their a way to check if its disabled or not?
m
0
l
Related resources
December 28, 2010 2:33:30 PM

Sorry for the bump but I really want to get this solved asap.
m
0
l

Best solution

a c 347 } Memory
December 28, 2010 3:15:29 PM

Often when RAM is mismatched the BIOS disables it to prevent errors; they don't work together.

Try the following:
1. Swap positions of RAM
2. Kingston only
3. Nanya only

If both 'work' alone then: 1. Disable Memory remapping, 2. Get a second stick of the same Kingston.
Share
December 28, 2010 3:35:52 PM

Yes both do work alone and both slots work. I don't have any memory options in my bios in order to disable memory remapping. I'll try a second Kingston then.
m
0
l
a c 347 } Memory
December 28, 2010 3:52:15 PM

I see 5~10 of your type situations a day.

As a last resort you can try cleaning with Isopropyl alcohol - dampen the RAM contacts, insert then remove, dampen and repeat once again. Allow 10 minutes to dry out and try again.
m
0
l
December 28, 2010 4:24:41 PM

Thank you, I tried another ddr2 4200 and worked with the nanaya but didnt with the kingston. Both rams were mismatches. I'll probably just return the kingston and get a 2gb ddr 2 5300(they are on sale at a store nearby) stick and take out the nanaya as well.

Thank for your replies and sorry if you got annoyed by such a common topic.
m
0
l
December 28, 2010 4:25:03 PM

Best answer selected by Bazgod.
m
0
l
a c 347 } Memory
December 28, 2010 4:40:38 PM

Never annoyed, you have to remember you're dealing with a component that is based on billionths of a second to be good, bad, or incompatible. I just wanted you to feel less concerned about the PC as a whole and the solution as a 'simple' fix.

People place a lesser value than they 'should' on RAM.

Good Luck! :sol: 
m
0
l
!