Solved

The Vanishing Raid 5

hello all,

so i have tough issue that after much much googling and trouble shooting, i cant figure out. I have a windows home server 2011 system that houses three raid controllers (1 on board, 1 pci-x and 1 pci) about 11 hard drives total that consists of 2 raid 5's and 2 raid 1's. (i will follow up this post with the specs)

so, i was having some issues with the secondary raid 5 and windows. It first started out with the raid dropping while under a heavy load. (this was before purchasing the pci-x contoller). so i thought this may have to do with a irq issue with the pci controllers. Bought a pci-x controller and everything is fine, until i need to reboot....


windows hangs on reboot (loading into safe mode, it looks like the storport.sys), it only boots when i break the raid 5 on the pci-x controller.

any ideas as to why? i'm going nuts trying to figure this out and before i throw this thing off the empire state building, i would like to get it to work.

Thanks!
12 answers Last reply Best Answer
More about vanishing raid
  1. This may be a longshot... But 2 things come to mind.

    1. If the RAID size is over 2TB the BIOS may not know what to do with it, and may lock it up. If the other RAIDS are also over 2TB you can throw this one out the window.

    2. Is the PCIe RAID listed in the boot list? If so, windows might be trying to pull off of it, and getting confused.
  2. thats possibly the best reply i've heard so far....

    here is some more information:

    on board raid:

    raid 1 = 80 gigs total (this used to hold whs v1)

    raid 1 = 250 gigs total

    PCIe raid 5 = 1 tb total

    PCI raid 5 = 1.5 tb total

    nothing over 2 tb (yet anyway)

    All but the PCI raid is listed in the bios boot sequence. It appears when i disconnect the hdd's from the PCIe

    Though its not a solution, thats the best thing i heard for the past three weeks of searching. you maybe right, problem is how do i tell the bios which squence of pci controllers should post?

    i was thinking of breaking the on board raid's, backing up all my data, then adding another pci raid and make the raid 1's on those.... in other words, not using the on board raid controller at all...
  3. Specs:

    CORSAIR Builder Series CX600 V2 600W

    nvidia 6600

    BIOSTAR TA970XE AM3+ AMD 970

    AMD Athlon II X2 250 Regor 3.0GHz

    G.SKILL NS 4GB (2 x 2GB) DDR3 1333

    ON-Board Raid:

    Raid 1:

    2 x seagate 250gb barracuda (WHS 2011 installed)

    Raid 1:

    2 x maxtor 80gb (this used to hold WHS v1, I plan I replacing this soon)

    PCI Raid Controllers and Configuration:

    1st pci slot:

    Rocket raid 2640 PCIe

    1 x seagate pipeline 500 gb
    2 x seagate spinpoint 500gb

    2nd pci slot:

    MASSCOOL PCI Card 4 port sata: Raid 5

    1 x western digital black 750 gb

    1 x western digital green 750 gb ( I know its green, I will be replacing it soon)

    1 x samsung 750 gb
  4. Can you go into the BIOS and completely remove the RAIDS you do not boot from, from the boot list?
  5. i can "disable them" but, the're roms still POST...

    I'm not sure if this makes a difference, i tried to reinstall whs, but, same thing happened while loading the startup disk, the loader just hangs.
  6. i know there are ways to stop the cards from posting, i forget the exact bios options they are, when i get home from work, i'll play with them...
  7. Best answer
    If you stop the cards from posting, they won't appear once you finish booting.

    Just set the OS to first boot priority, and see if you can disable boot priority for the others.
  8. Ok, i'll give a shot. i'll keep you posted (no pun intended). thanks!
  9. no problem
  10. Update....

    so i tried to change the bootable drives, i managed to shutdown all other drives but the ones that i THOUGHT held whs bootstrap. In anycase, i decided to nuke the onboard raid controller, disabled it, slapped my spare pci raid controller back in and what do you know, it booted!!!!!!!

    i have no idea why the onboard controller doesnt play nice with more than three controllers, but no matter, it works and i'm happy!

    thanks daniel!!!
  11. That is baffling to me as well, but at least it is up and running. Glad you got it sorted out!
  12. Best answer selected by beezdat.
Ask a new question

Read More

NAS / RAID PCI Storage